Pull requests

#13 Merged
Repository
Deleted repository
Branch
default (b1f5815a9be9)
Repository
richard42/mupen64plus-video-glide64mk2 mupen64plus-video-glide64mk2
Branch
default

Don't use nonportable (and redundant) GCC construct.

Author
  1. bentley
Reviewers
Description

This breaks the build in GCC 4.2, which doesn't hvae __builtin_bswap32(). Plus, at -O2 the #else case generates equivalent assembly code.

In theory the GCC ≥ 4.3 requirement isn't a problem since glide64mk2 already requires 4.6 or later, but since this code has been copied/pasted to glide64 and may make its way into other plugins that don't require 4.6, we should avoid it.

  • Learn about pull requests

Comments (0)