Commits

Anonymous committed 49b08c9

updated for version 7.3.340
Problem: When 'verbosefile' is set ftplugof.vim can give an error.
Solution: Only remove filetypeplugin autocommands when they exist. (Yasuhiro
Matsumoto)

  • Participants
  • Parent commits 7182e0a
  • Tags v7-3-340

Comments (0)

Files changed (2)

File runtime/ftplugof.vim

 " Vim support file to switch off loading plugins for file types
 "
 " Maintainer:	Bram Moolenaar <Bram@vim.org>
-" Last Change:	2002 Apr 04
+" Last Change:	2011 Oct 20
 
 if exists("did_load_ftplugin")
   unlet did_load_ftplugin
 endif
 
-" Remove all autocommands in the filetypeplugin group
-silent! au! filetypeplugin *
+" Remove all autocommands in the filetypeplugin group, if any exist.
+if exists("#filetypeplugin")
+  silent! au! filetypeplugin *
+endif

File src/version.c

 static int included_patches[] =
 {   /* Add new patch number below this line */
 /**/
+    340,
+/**/
     339,
 /**/
     338,