Issue #117 resolved

frame number in references is wrong, when using subsections

A Mennucci avatarA Mennucci created an issue

hi,

if I use sections and subsections, then the frame number inserted by \ref-erencing to the label of another frame is wrong. The problem is that there is a counter called 'subsectionslide' that counts the number of slides since the last \subsection; the bug is that it is incremented by \refstepcounter, so this is what is (wrongly) associated to the label. I attach a test file showing the problem; and the patch (for beamer 3.10).

a.

ps: this was posted as bug 2089504 in sourceforge, together with a patch, but the patch was never applied; I hope this time it is.

Comments (8)

  1. A Mennucci

    For your convenience, here is an example short code (but I recommend at looking at the attached example)

    \begin{frame}
      see frame \ref{HIframe}
    \end{frame}
    \subsection{sec3sub1}
    \begin{frame}\label{HIframe}
     HI
    \end{frame}
    

    If you use \subsections in the document, then the numbers shown by \ref are wrong (see attachment example)

    a.

  2. Log in to comment
Tip: Filter by directory path e.g. /media app.js to search for public/media/app.js.
Tip: Use camelCasing e.g. ProjME to search for ProjectModifiedEvent.java.
Tip: Filter by extension type e.g. /repo .js to search for all .js files in the /repo directory.
Tip: Separate your search with spaces e.g. /ssh pom.xml to search for src/ssh/pom.xml.
Tip: Use ↑ and ↓ arrow keys to navigate and return to view the file.
Tip: You can also navigate files with Ctrl+j (next) and Ctrl+k (previous) and view the file with Ctrl+o.
Tip: You can also navigate files with Alt+j (next) and Alt+k (previous) and view the file with Alt+o.