Issue #23 duplicate

textblock and \setbeameroption{show notes on second screen}

Anonymous created an issue

Hi,

I may have found a bug when using textblock and \setbeameroption{show notes on second screen}

== Normal case == Here is a simple example : two frames. There is a textblock on the second.

{{{ \documentclass{beamer} \usepackage[latin1]{inputenc} \usepackage[absolute,overlay]{textpos}

\begin{document}

\begin{frame}
    Frame 1
\end{frame}

\begin{frame}
    Frame 2
    \begin{textblock}{5}[0,0](5,5)
        Mon textblock
    \end{textblock}
\end{frame}

\end{document} }}}

Here every thing is okay. The textblock appears on the second slide.

== The bug ==

Then, I want to display the notes with \setbeameroption{show notes on second screen} {{{ \documentclass{beamer} \usepackage[latin1]{inputenc} \usepackage[absolute,overlay]{textpos}

\usepackage{pgfpages} \setbeameroption{show notes on second screen=right}

\begin{document}

\begin{frame}
    Frame 1
\end{frame}

\begin{frame}
    Frame 2
    \begin{textblock}{5}[0,0](5,5)
        Mon textblock
    \end{textblock}
\end{frame}

\end{document} }}}

MikTex 2.7

Comments (8)

  1. Anonymous

    I didn't explained the result...

    When I use \setbeameroption{show notes on second screen=right}, the textblock appears on the first slide instead of on the second slide.

  2. Anonymous

    I didn't explained the result...

    When I use \setbeameroption{show notes on second screen=right}, the textblock appears on the first slide instead of on the second slide.

  3. Anonymous

    Oops! Sorry for this double post, and for the "Bump!" (I didn't know the effect on this button...)

    Thank you rivanvx.

    Morgan

  4. Anonymous

    The problem seems to to be related to dual-screen mode in particular, but to any transformations performed by pgfpages (scaling, nup, whatsoever), which internally is used by a lot of beamer features. Apparently, pgfpages transformations just have no effect on the content inserted by textpos. Both perform their manipulations at shipout-time, which probably is the reason for the troubles.

    Unfortunately, I have not yet found another way to put stuff to absolute coordinates on beamer slides. (I have tried with TiKZ "current page" node, which works fine in text documents, but with beamer slides the result wasn't really absolute positioning.)

    Daniel

  5. Log in to comment