Issue #10 resolved

Problem with ClassRCS and PackageRCS from beamerbasercs

created an issue

I've downloaded beamer-tip and tested with

\documentclass{beamer} \begin{document} \begin{frame} Hello \end{frame} \end{document}

console output shows:

This is pdfTeX, Version 3.1415926-1.40.10 (MiKTeX 2.8) entering extended mode (D:\Documents\CosesLatex\beamer\sensetitol-1.tex LaTeX2e <2009/09/24> Babel <v3.8l> and hyphenation patterns for english, dumylang, nohyphenation, ge rman, ngerman, german-x-2009-06-19, ngerman-x-2009-06-19, spanish, catalan, fre nch, loaded. (D:\ExperimentsLatex\tex\latex\beamer\base\beamer.cls (D:\ExperimentsLatex\tex\latex\beamer\base\beamerbasercs.sty Runaway argument? Header$ \ProvidesPackage {\beamer@rcsfile }[\beamer@rcsdate \space (r\ETC. ! Paragraph ended before \beamer@parseid was complete. <to be read again> \par l.40

? e No pages of output. Transcript written on sensetitol-1.log.

What's wrong? I'm using MiKTeX2.8 updated this week. Beamer-3.07-cvs version works.

Thank you,


Comments (22)

  1. Joseph Wright

    Remember that development "bleeding edge" stuff does not always work 100% perfectly. In this case, I wonder if you've been bitten by differences between Subversion and Mercurial. Keywords are "native" in Subversion, and are an extension in Mercurial. I think Vedran is still experimenting a bit with this!

  2. Vedran Miletić repo owner
    • changed status to open

    Joseph is right. You need properly configured KeywordExtension for this to work. I planned to put this on wiki this weekend (and when I do, I will close this bug), but since you asked: Put this into .hg/hgrc of the beamer repository (you can even put it in .hgrc, but it's not recommended):

    keyword =
    **.cls =
    **.tex =
    **.sty =
    Header = {root}/{file},v {node|short} {date|utcdate} {author|user}

    And then use hg kwexpand to expand the keywords.

    This will probably be around for a while, but release versions will always have it sorted out requiring no user intervention.

    Oh, if this sounds too complicated, you can usually skip these by just pressing <enter> enough many times. It's not really a solution, but it works :-)

  3. Anonymous

    I'm having the same problem as ignasi, with all the three versions 3.06,3.07,tip. I don't understand the instructions from Vedran's message. Could you please explain in more detail? For example, what is .hg/hgrc ?

    I have Windows 7 and I use TeXnicCenter or TeXworks to edit Latex.


  4. ignasi reporter


    I just followed Vedran instructions.

    1.- It's suposed that you will find the folder .hg into your "beamer-tip" folder. There you will find a file called hgrc where you must add those lines.

    2.- Expand keywords with command hg kwexpand.

    I've no idea about what's the meaning of these instructions but they worked for me.

  5. Anonymous

    Hello, having exact same problem. I'm *not* pulling this with a VC system though, I just download the zip file of 3.07 straight from this site. Therefore, I have no .hg directory to make these modifications. I would like 3.07 since beamerposter package is not working with 3.10.

    Does CTAN still have their version of 3.07 anywhere, I can't seem to find it, but think that would solve my issue.

    Thanks for a great package!

  6. bthomson

    I got hit by this bug with the 3.10 zip download and the fix didn't work (probably 'cos there is no hg repo included, just creating the file is not good enough) but it worked fine when downloading tip with hg clone. So, try that if you have problems with the zips.

    Thanks for the fix!

  7. Anonymous

    Adding to comment #5 from ignasi: You have to install the "mecurial" package to be able to use a "hg" command (for Linux):

    apt-get install mercurial


    yum --enablerepo=* install mercurial

    or any other method that your distro uses

    With that you can install the beamer repo with "hg clone", then in subdir beamer you have a .hg dir and a .hg/hgrc file. After that you can use the tips mentioned in comment #2 from Vedran.

  8. Anonymous

    Here is the head of the base/beamer.cls file coming from the released package beamer-3.10.tar.bz2 . As you notice, \ProvidesClassRCS has not a generic path. It can't work well out of the box. Is it possible to have a clean package to download ? I stay on latex-beamer-3.07 because of that ! Thanks...

    % Copyright 2003--2007 by Till Tantau % Copyright 2010 by Vedran Mileti\'c % % This file may be distributed and/or modified % % 1. under the LaTeX Project Public License and/or % 2. under the GNU Public License. % % See the file doc/licenses/LICENSE for more details.

    \RequirePackage{beamerbasercs} \ProvidesClassRCS $Header: /home/vedranm/bitbucket/beamer/base/beamer.cls,v a6b1a8434d30 2010/06/21 09:34:49 rivanvx $

  9. Anonymous

    When I run beamer it gives

    ! Undefined control sequence. \beamer@frameslide ...duration=}\thispdfpagelabel {\insertframenumber } \xde... l.133 \end{frame}

    several times. Please solve

  10. Anonymous

    This problem has not been solved! I have downloaded version 3.10 today and installed according to the manual instructions and one what #2 says in the .hg files but it still gives the same error! Can you fix this please or tell us exactly what we should do? Thanks...

  11. Anonymous


    1. open the "beamer.cls" and "beamerbasercs.sty"
    2. replace the whole line "\ProvidesPackageRCS $Header$" to "\ProvidesPackageRCS $Header: beamer.cls,v 70f9d8411e54 2011/09 $" in both files. [without symbol " ][within ONE LINE]
    3. save

    then it just works!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

  12. Log in to comment