1. Vedran Miletić
  2. beamer
Issue #69 resolved

errors in beamerarticle in tl-2010

georgd
created an issue

the current version of beamerbasearticle.sty seems to produce errors. the first is an option clash for package xcolor, that won’t show up if noxcolor is selected, the others i don’t understand.

my minimal example is:

\documentclass{beamer} \usepackage{beamerarticle} \begin{document} \frame{Test} \end{document}

attached you find the logfile.

Comments (9)

  1. georgd reporter

    sorry, i have followed my old habits and my system still seems to show the old manuals.

    now following the current manual, i still get an error when i try to compile an article–seems it doesn’t like the overlayspecifications directly after \begin{itemize}. The problem disappears if i comment out the [<+->]

    \documentclass{scrartcl} \usepackage{beamerarticle} %\documentclass{beamer} \begin{document} \begin{frame} \frametitle{A frame title} \begin{itemize}[<+->] \item You can use overlay specifications. \item This is useful. \end{itemize} \end{frame} \end{document}

  2. Joseph Wright

    Okay, I have a possible solution. There are two requirements here

    • Work with the enumerate package
    • Remove any overlay specs in article mode

    The cleanest way to do this is I think to require the enumerate package in all cases. There is then just a need to 'break in' to the argument grabbing that it does and to pick up anything that reads

    [<...>]
    

    and remove it. That is easy enough to do (after all, in presentation mode this is more or less what happens now). The only risk is that this is a change when in article mode (as enumerate is always going to be loaded). If this seems like an acceptable solution I have the code ready to go.

  3. Log in to comment