Version 0.14 complies apps that fail to open on MacOS 10.10.5

Issue #8 resolved
Kris Kringle
created an issue

Using py2app 0.14 installed through pip 9.0.1 python 3.6.3 MacOSX 10.10.5

For simplicity sake I am using the tkinter hello world example:

hello.py

import tkinter from tkinter.constants import *

tk = tkinter.Tk() frame = tkinter.Frame(tk, relief=RIDGE, borderwidth=2) frame.pack(fill=BOTH,expand=1) label = tkinter.Label(frame, text="Hello, World") label.pack(fill=X, expand=1) button = tkinter.Button(frame,text="Exit",command=tk.destroy) button.pack(side=BOTTOM) tk.mainloop()

I run py2applet --make-setup hello.py which makes a setup file

""" This is a setup.py script generated by py2applet

Usage: python setup.py py2app """

from setuptools import setup

APP = ['hello.py'] DATA_FILES = [] OPTIONS = {}

setup( app=APP, data_files=DATA_FILES, options={'py2app': OPTIONS}, setup_requires=['py2app'], )

I then run python setup.py py2app -A to develop in Alias mode and it makes the build and dist folders.

Now, no matter how I try to open the application (double click or via terminal) it fails with a hello Error and gives two options. Open Console or Terminate

Looking at console, there is only one line that pops up from the error.

It reads, hello: hello Error.

That is it. I have tried adding the 'argv_emulation': True to the setup.py OPTIONS No change. I have tried it in deployment mode. No change. Also, whatever I name the program is the name of the error. If I were to name the program test, it would fail with test Error

What am I missing to get this going?

Comments (2)

  1. Log in to comment