When run the app OS will restart ,on MacOS 10.14.6!

Issue #267 new
hufang created an issue

Recently I upgraded the OS from 10.14.5 to 10.14.6, When run the app, os will reboot.

My os will automatic running last runing app when the reboot, after the reboot appear agrain, agrain and agrain, it’s so bad, Fortunately, Finaly,i success stop app.

I run the py files, it it works!

The python version is 3.7.4.

The py2app version is 0.19

I’am record the video,and provide the py2app config, please see:

https://drive.google.com/drive/folders/13usv6nEBPuWEGUmKqdI8OT-qKNK_BrfW?usp=sharing

Thanks!

Comments (13)

  1. Adam Kollgaard

    I just wanted to confirm this problem.

    I have also had this problem as well. I have multiple projects that do various things which where created with py2app. Each of them use the Tkinter library. Once the application opens a white cut-out of the window appears for a second then my Mac signs me out. Here is a small snippet of code that recreates the problem.

    import tkinter as tk
    
    root = tk.Tk()
    root.title("foo")
    
    label = tk.Label(root, text="Is it working?")
    label.grid(row=0, columnspan=2, padx=20, pady=20)
    
    yesButton = tk.Button(root, text="yes")
    noButton = tk.Button(root, text="no")
    yesButton.grid(row=1, column=0, padx=20, pady=20)
    noButton.grid(row=1, column=1, padx=20, pady=20)
    
    root.mainloop()
    

    I am running on the new Mac os 10.14.6 with the latest version of py2app 0.19.

  2. Ronald Oussoren repo owner

    There’s a problem with Tkinter on the latest release of macOS 10.14, see this issue on the Python tracker: https://bugs.python.org/issue37833.

    As I wrote there this is almost certainly a bug in macOS, hopefully this can be worked around in either Tk or Python. Sadly there’s nothing I can do about this in py2app.

  3. Ronald Oussoren repo owner

    I do have an additional question for both of you: How did you install Python? Did you use the Python.org installer, anaconda, homebrew, …?

    The Python.org issue also mentions that knowing the exact Tk version would be useful, but I don’t know how to determine that.

  4. Adam Kollgaard

    I personally installed python with the python.org installer. I’m not sure on the exact Tk version though I will try to get back to you soon when I found out. Reading the page that you mentioned it seems that it might be a while before it gets fixed assuming that it is a python problem.

    Edit - Okay so I just found out the my Tk version. I am running 8.6.8. And confirmed that it is with the python installer. I used what it said in the other forum.

  5. Ronald Oussoren repo owner

    This is definitely a crashing bug in macOS (in particular the WindowServer) and I’ve filed a report with Apple about this. Feedback report number: FB7028614

    That said, this crashing bug is triggered when using py2app and not when the script isn’t packaged with py2app. I’m trying to find a workaround for this that I can use in py2app.

  6. Ronald Oussoren repo owner

    This is a pretty annoying issue to work on, every attempt at fixing this takes a lot of time due to having to log back in on my test vm (as WindowServer crashes). I do not yet have a clue as to how I can work around this issue.

  7. Adam Kollgaard

    I would like to help, but my background in Mac OS especially WindowServer is quite limited. I could not think of any way to work around the issue because it seems something that controlled by the OS which does not have any easily accessible setting. I hope that you are successful in finding a way to work around this issue.

  8. Log in to comment