Commits

Ronald Oussoren committed 97100ba Merge

Bump version in trunk

Comments (0)

Files changed (40)

pyobjc-core/Modules/objc/pyobjc.h

  * Central include file for PyObjC. 
  */
 
-#define OBJC_VERSION "2.4"
+#define OBJC_VERSION "2.5.0b1"
 
 // Loading in AppKit on Mac OS X 10.3 results in
 // a bit less than 1500 classes.

pyobjc-framework-Accounts/setup.py

 
 setup(
     name='pyobjc-framework-Accounts',
-    version="2.4",
+    version="2.5.0b1",
     description = "Wrappers for the framework Accounts on Mac OS X",
     packages = [ "Accounts" ],
     setup_requires = [
-        'pyobjc-core>=2.4',
+        'pyobjc-core>=2.5.0b1',
     ],
     install_requires = [ 
-        'pyobjc-core>=2.4',
-        'pyobjc-framework-Cocoa>=2.4',
+        'pyobjc-core>=2.5.0b1',
+        'pyobjc-framework-Cocoa>=2.5.0b1',
     ],
     min_os_level="10.8",
 )

pyobjc-framework-AddressBook/setup.py

 
 setup(
     name='pyobjc-framework-AddressBook',
-    version="2.4",
+    version="2.5.0b1",
     description = "Wrappers for the framework AddressBook on Mac OS X",
     packages = [ "AddressBook" ],
     setup_requires = [
-        'pyobjc-core>=2.4',
+        'pyobjc-core>=2.5.0b1',
     ],
     install_requires = [ 
-        'pyobjc-core>=2.4',
-        'pyobjc-framework-Cocoa>=2.4',
+        'pyobjc-core>=2.5.0b1',
+        'pyobjc-framework-Cocoa>=2.5.0b1',
     ],
 )

pyobjc-framework-AppleScriptKit/setup.py

 
 setup(
     name='pyobjc-framework-AppleScriptKit',
-    version="2.4",
+    version="2.5.0b1",
     description = "Wrappers for the framework AppleScriptKit on Mac OS X",
     packages = [ "AppleScriptKit" ],
     setup_requires = [
-        'pyobjc-core>=2.4',
+        'pyobjc-core>=2.5.0b1',
     ],
     install_requires = [ 
-        'pyobjc-core>=2.4',
-        'pyobjc-framework-Cocoa>=2.4',
+        'pyobjc-core>=2.5.0b1',
+        'pyobjc-framework-Cocoa>=2.5.0b1',
     ],
 )

pyobjc-framework-AppleScriptObjC/setup.py

 setup(
     min_os_level='10.6',
     name='pyobjc-framework-AppleScriptObjC',
-    version="2.4",
+    version="2.5.0b1",
     description = "Wrappers for the framework AppleScriptObjC on Mac OS X",
     packages = [ "AppleScriptObjC" ],
     setup_requires = [
-        'pyobjc-core>=2.4',
+        'pyobjc-core>=2.5.0b1',
     ],
     install_requires = [ 
-        'pyobjc-core>=2.4',
-        'pyobjc-framework-Cocoa>=2.4',
+        'pyobjc-core>=2.5.0b1',
+        'pyobjc-framework-Cocoa>=2.5.0b1',
     ],
 )

pyobjc-framework-Automator/setup.py

 
 setup(
     name='pyobjc-framework-Automator',
-    version="2.4",
+    version="2.5.0b1",
     description = "Wrappers for the framework Automator on Mac OS X",
     packages = [ "Automator" ],
     setup_requires = [
-        'pyobjc-core>=2.4',
+        'pyobjc-core>=2.5.0b1',
     ],
     install_requires = [ 
-        'pyobjc-core>=2.4',
-        'pyobjc-framework-Cocoa>=2.4',
+        'pyobjc-core>=2.5.0b1',
+        'pyobjc-framework-Cocoa>=2.5.0b1',
     ],
 )

pyobjc-framework-CFNetwork/setup.py

 
 setup(
     name='pyobjc-framework-CFNetwork',
-    version="2.4",
+    version="2.5.0b1",
     description = "Wrappers for the framework CFNetwork on Mac OS X",
     packages = [ "CFNetwork" ],
     setup_requires = [
-        'pyobjc-core>=2.4',
+        'pyobjc-core>=2.5.0b1',
     ],
     install_requires = [ 
-        'pyobjc-core>=2.4',
-        'pyobjc-framework-Cocoa>=2.4',
+        'pyobjc-core>=2.5.0b1',
+        'pyobjc-framework-Cocoa>=2.5.0b1',
     ],
     ext_modules = [
         Extension("CFNetwork._manual",

pyobjc-framework-CalendarStore/setup.py

 setup(
     min_os_level='10.5',
     name='pyobjc-framework-CalendarStore',
-    version="2.4",
+    version="2.5.0b1",
     description = "Wrappers for the framework CalendarStore on Mac OS X",
     packages = [ "CalendarStore" ],
     setup_requires = [
-        'pyobjc-core>=2.4',
+        'pyobjc-core>=2.5.0b1',
     ],
     install_requires = [ 
-        'pyobjc-core>=2.4',
-        'pyobjc-framework-Cocoa>=2.4',
+        'pyobjc-core>=2.5.0b1',
+        'pyobjc-framework-Cocoa>=2.5.0b1',
     ],
 )

pyobjc-framework-Cocoa/setup.py

 
 setup(
     name='pyobjc-framework-Cocoa',
-    version="2.4",
+    version="2.5.0b1",
     description = "Wrappers for the Cocoa frameworks on Mac OS X",
     packages = [ "Cocoa", "CoreFoundation", "Foundation", "AppKit", "PyObjCTools" ],
     namespace_packages = ['PyObjCTools'],
     setup_requires = [
-        'pyobjc-core>=2.4',
+        'pyobjc-core>=2.5.0b1',
     ],
     install_requires = [ 
-        'pyobjc-core>=2.4',
+        'pyobjc-core>=2.5.0b1',
     ],
     ext_modules = [
         # CoreFoundation

pyobjc-framework-Collaboration/setup.py

 setup(
     min_os_level='10.5',
     name='pyobjc-framework-Collaboration',
-    version="2.4",
+    version="2.5.0b1",
     description = "Wrappers for the framework Collaboration on Mac OS X",
     packages = [ "Collaboration" ],
     setup_requires = [
-        'pyobjc-core>=2.4',
+        'pyobjc-core>=2.5.0b1',
     ],
     install_requires = [ 
-        'pyobjc-core>=2.4',
-        'pyobjc-framework-Cocoa>=2.4',
+        'pyobjc-core>=2.5.0b1',
+        'pyobjc-framework-Cocoa>=2.5.0b1',
     ],
 )

pyobjc-framework-CoreData/setup.py

 from pyobjc_setup import *
 setup(
     name='pyobjc-framework-CoreData',
-    version="2.4",
+    version="2.5.0b1",
     description = "Wrappers for the framework CoreData on Mac OS X",
     packages = [ "CoreData" ],
     setup_requires = [
-        'pyobjc-core>=2.4',
+        'pyobjc-core>=2.5.0b1',
     ],
     install_requires = [ 
-        'pyobjc-core>=2.4',
-        'pyobjc-framework-Cocoa>=2.4',
+        'pyobjc-core>=2.5.0b1',
+        'pyobjc-framework-Cocoa>=2.5.0b1',
     ],
 )

pyobjc-framework-CoreLocation/setup.py

 setup(
     min_os_level='10.6',
     name='pyobjc-framework-CoreLocation',
-    version="2.4",
+    version="2.5.0b1",
     description = "Wrappers for the framework CoreLocation on Mac OS X",
     packages = [ "CoreLocation" ],
     setup_requires = [
-        'pyobjc-core>=2.4',
+        'pyobjc-core>=2.5.0b1',
     ],
     install_requires = [ 
-        'pyobjc-core>=2.4',
-        'pyobjc-framework-Cocoa>=2.4',
+        'pyobjc-core>=2.5.0b1',
+        'pyobjc-framework-Cocoa>=2.5.0b1',
     ],
 )

pyobjc-framework-CoreText/setup.py

 setup(
     min_os_level='10.5',
     name='pyobjc-framework-CoreText',
-    version="2.4",
+    version="2.5.0b1",
     description = "Wrappers for the framework CoreText on Mac OS X",
     packages = [ "CoreText" ],
     ext_modules = [
             ),
     ],
     setup_requires = [
-        'pyobjc-core>=2.4',
+        'pyobjc-core>=2.5.0b1',
     ],
     install_requires = [ 
-        'pyobjc-core>=2.4',
-        'pyobjc-framework-Cocoa>=2.4',
-        'pyobjc-framework-Quartz>=2.4',
+        'pyobjc-core>=2.5.0b1',
+        'pyobjc-framework-Cocoa>=2.5.0b1',
+        'pyobjc-framework-Quartz>=2.5.0b1',
     ],
 )

pyobjc-framework-DictionaryServices/setup.py

 setup(
     min_os_level='10.5',
     name='pyobjc-framework-DictionaryServices',
-    version="2.4",
+    version="2.5.0b1",
     description = "Wrappers for the framework DictionaryServices on Mac OS X",
     packages = [ "DictionaryServices" ],
     setup_requires = [
-        'pyobjc-core>=2.4',
+        'pyobjc-core>=2.5.0b1',
     ],
     install_requires = [ 
-        'pyobjc-core>=2.4',
-        'pyobjc-framework-Cocoa>=2.4',
+        'pyobjc-core>=2.5.0b1',
+        'pyobjc-framework-Cocoa>=2.5.0b1',
     ],
 )

pyobjc-framework-EventKit/setup.py

 
 setup(
     name='pyobjc-framework-EventKit',
-    version="2.4",
+    version="2.5.0b1",
     description = "Wrappers for the framework Accounts on Mac OS X",
     packages = [ "EventKit" ],
     setup_requires = [
-        'pyobjc-core>=2.4',
+        'pyobjc-core>=2.5.0b1',
     ],
     install_requires = [ 
-        'pyobjc-core>=2.4',
-        'pyobjc-framework-Cocoa>=2.4',
+        'pyobjc-core>=2.5.0b1',
+        'pyobjc-framework-Cocoa>=2.5.0b1',
     ],
     min_os_level="10.8",
 )

pyobjc-framework-ExceptionHandling/setup.py

 
 setup(
     name='pyobjc-framework-ExceptionHandling',
-    version="2.4",
+    version="2.5.0b1",
     description = "Wrappers for the framework ExceptionHandling on Mac OS X",
     packages = [ "PyObjCTools", "ExceptionHandling" ],
     namespace_packages = [ "PyObjCTools" ],
     setup_requires = [
-        'pyobjc-core>=2.4',
+        'pyobjc-core>=2.5.0b1',
     ],
     install_requires = [ 
-        'pyobjc-core>=2.4',
-        'pyobjc-framework-Cocoa>=2.4',
+        'pyobjc-core>=2.5.0b1',
+        'pyobjc-framework-Cocoa>=2.5.0b1',
     ],
 )

pyobjc-framework-FSEvents/setup.py

 setup(
     min_os_level='10.5',
     name='pyobjc-framework-FSEvents',
-    version="2.4",
+    version="2.5.0b1",
     description = "Wrappers for the framework FSEvents on Mac OS X",
     packages = [ "FSEvents" ],
     setup_requires = [
-        'pyobjc-core>=2.4',
+        'pyobjc-core>=2.5.0b1',
     ],
     install_requires = [ 
-        'pyobjc-core>=2.4',
-        'pyobjc-framework-Cocoa>=2.4',
+        'pyobjc-core>=2.5.0b1',
+        'pyobjc-framework-Cocoa>=2.5.0b1',
     ],
     ext_modules = [
         Extension("FSEvents._callbacks",

pyobjc-framework-InputMethodKit/setup.py

 setup(
     min_os_level='10.5',
     name='pyobjc-framework-InputMethodKit',
-    version="2.4",
+    version="2.5.0b1",
     description = "Wrappers for the framework InputMethodKit on Mac OS X",
     packages = [ "InputMethodKit" ],
     setup_requires = [
-        'pyobjc-core>=2.4',
+        'pyobjc-core>=2.5.0b1',
     ],
     install_requires = [ 
-        'pyobjc-core>=2.4',
-        'pyobjc-framework-Cocoa>=2.4',
+        'pyobjc-core>=2.5.0b1',
+        'pyobjc-framework-Cocoa>=2.5.0b1',
     ],
 )

pyobjc-framework-InstallerPlugins/setup.py

 
 setup(
     name='pyobjc-framework-InstallerPlugins',
-    version="2.4",
+    version="2.5.0b1",
     description = "Wrappers for the framework InstallerPlugins on Mac OS X",
     packages = [ "InstallerPlugins" ],
     setup_requires = [
-        'pyobjc-core>=2.4',
+        'pyobjc-core>=2.5.0b1',
     ],
     install_requires = [ 
-        'pyobjc-core>=2.4',
-        'pyobjc-framework-Cocoa>=2.4',
+        'pyobjc-core>=2.5.0b1',
+        'pyobjc-framework-Cocoa>=2.5.0b1',
     ],
 )

pyobjc-framework-InstantMessage/setup.py

 setup(
     min_os_level='10.5',
     name='pyobjc-framework-InstantMessage',
-    version="2.4",
+    version="2.5.0b1",
     description = "Wrappers for the framework InstantMessage on Mac OS X",
     packages = [ "InstantMessage" ],
     setup_requires = [
-        'pyobjc-core>=2.4',
+        'pyobjc-core>=2.5.0b1',
     ],
     install_requires = [ 
-        'pyobjc-core>=2.4',
-        'pyobjc-framework-Cocoa>=2.4',
-        'pyobjc-framework-Quartz>=2.4',
+        'pyobjc-core>=2.5.0b1',
+        'pyobjc-framework-Cocoa>=2.5.0b1',
+        'pyobjc-framework-Quartz>=2.5.0b1',
     ],
 )

pyobjc-framework-InterfaceBuilderKit/setup.py

     min_os_level='10.5',
     max_os_level='10.6',
     name='pyobjc-framework-InterfaceBuilderKit',
-    version="2.4",
+    version="2.5.0b1",
     description = "Wrappers for the framework InterfaceBuilderKit on Mac OS X",
     packages = [ "InterfaceBuilderKit" ],
     setup_requires = [
-        'pyobjc-core>=2.4',
+        'pyobjc-core>=2.5.0b1',
     ],
     install_requires = [ 
-        'pyobjc-core>=2.4',
-        'pyobjc-framework-Cocoa>=2.4',
+        'pyobjc-core>=2.5.0b1',
+        'pyobjc-framework-Cocoa>=2.5.0b1',
     ],
 )

pyobjc-framework-LatentSemanticMapping/setup.py

 setup(
     min_os_level='10.5',
     name='pyobjc-framework-LatentSemanticMapping',
-    version="2.4",
+    version="2.5.0b1",
     description = "Wrappers for the framework LatentSemanticMapping on Mac OS X",
     packages = [ "LatentSemanticMapping" ],
     setup_requires = [
-        'pyobjc-core>=2.4',
+        'pyobjc-core>=2.5.0b1',
     ],
     install_requires = [ 
-        'pyobjc-core>=2.4',
-        'pyobjc-framework-Cocoa>=2.4',
+        'pyobjc-core>=2.5.0b1',
+        'pyobjc-framework-Cocoa>=2.5.0b1',
     ],
 )

pyobjc-framework-LaunchServices/setup.py

 
 setup(
     name='pyobjc-framework-LaunchServices',
-    version="2.4",
+    version="2.5.0b1",
     description = "Wrappers for the framework LaunchServices on Mac OS X",
     packages = [ "LaunchServices" ],
     setup_requires = [
-        'pyobjc-core>=2.4',
+        'pyobjc-core>=2.5.0b1',
     ],
     install_requires = [ 
-        'pyobjc-core>=2.4',
-        'pyobjc-framework-Cocoa>=2.4',
+        'pyobjc-core>=2.5.0b1',
+        'pyobjc-framework-Cocoa>=2.5.0b1',
     ],
 )

pyobjc-framework-Message/setup.py

 from pyobjc_setup import setup
 setup(
     name='pyobjc-framework-Message',
-    version="2.4",
+    version="2.5.0b1",
     description = "Wrappers for the framework Message on Mac OS X",
     packages = [ "Message" ],
     setup_requires = [
-        'pyobjc-core>=2.4',
+        'pyobjc-core>=2.5.0b1',
     ],
     install_requires = [ 
-        'pyobjc-core>=2.4',
-        'pyobjc-framework-Cocoa>=2.4',
+        'pyobjc-core>=2.5.0b1',
+        'pyobjc-framework-Cocoa>=2.5.0b1',
     ],
 )

pyobjc-framework-OpenDirectory/setup.py

 setup(
     min_os_level='10.6',
     name='pyobjc-framework-OpenDirectory',
-    version="2.4",
+    version="2.5.0b1",
     description = "Wrappers for the framework OpenDirectory on Mac OS X",
     packages = [ "OpenDirectory", "CFOpenDirectory" ],
     setup_requires = [
-        'pyobjc-core>=2.4',
+        'pyobjc-core>=2.5.0b1',
     ],
     install_requires = [ 
-        'pyobjc-core>=2.4',
-        'pyobjc-framework-Cocoa>=2.4',
+        'pyobjc-core>=2.5.0b1',
+        'pyobjc-framework-Cocoa>=2.5.0b1',
     ],
 )

pyobjc-framework-PreferencePanes/setup.py

 from pyobjc_setup import *
 setup(
     name='pyobjc-framework-PreferencePanes',
-    version="2.4",
+    version="2.5.0b1",
     description = "Wrappers for the framework PreferencePanes on Mac OS X",
     packages = [ "PreferencePanes" ],
     setup_requires = [
-        'pyobjc-core>=2.4',
+        'pyobjc-core>=2.5.0b1',
     ],
     install_requires = [ 
-        'pyobjc-core>=2.4',
-        'pyobjc-framework-Cocoa>=2.4',
+        'pyobjc-core>=2.5.0b1',
+        'pyobjc-framework-Cocoa>=2.5.0b1',
     ],
 )

pyobjc-framework-PubSub/setup.py

 setup(
     min_os_level='10.5',
     name='pyobjc-framework-PubSub',
-    version="2.4",
+    version="2.5.0b1",
     description = "Wrappers for the framework PubSub on Mac OS X",
     packages = [ "PubSub" ],
     setup_requires = [
-        'pyobjc-core>=2.4',
+        'pyobjc-core>=2.5.0b1',
     ],
     install_requires = [ 
-        'pyobjc-core>=2.4',
-        'pyobjc-framework-Cocoa>=2.4',
+        'pyobjc-core>=2.5.0b1',
+        'pyobjc-framework-Cocoa>=2.5.0b1',
     ],
 )

pyobjc-framework-QTKit/setup.py

 
 setup(
     name='pyobjc-framework-QTKit',
-    version="2.4",
+    version="2.5.0b1",
     description = "Wrappers for the framework QTKit on Mac OS X",
     packages = [ "QTKit" ],
     setup_requires = [
-        'pyobjc-core>=2.4',
+        'pyobjc-core>=2.5.0b1',
     ],
     install_requires = [ 
-        'pyobjc-core>=2.4',
-        'pyobjc-framework-Cocoa>=2.4',
-        'pyobjc-framework-Quartz>=2.4',
+        'pyobjc-core>=2.5.0b1',
+        'pyobjc-framework-Cocoa>=2.5.0b1',
+        'pyobjc-framework-Quartz>=2.5.0b1',
     ],
 )

pyobjc-framework-Quartz/setup.py

 
 setup(
     name='pyobjc-framework-Quartz',
-    version="2.4",
+    version="2.5.0b1",
     description = "Wrappers for the Quartz frameworks on Mac OS X",
     packages = [ "Quartz" ] + subpackages,
     setup_requires = [
-        'pyobjc-core>=2.4',
+        'pyobjc-core>=2.5.0b1',
     ],
     install_requires = [ 
-        'pyobjc-core>=2.4',
-        'pyobjc-framework-Cocoa>=2.4',
+        'pyobjc-core>=2.5.0b1',
+        'pyobjc-framework-Cocoa>=2.5.0b1',
     ],
     ext_modules = [
         # CoreVideo

pyobjc-framework-ScreenSaver/setup.py

 
 setup(
     name='pyobjc-framework-ScreenSaver',
-    version="2.4",
+    version="2.5.0b1",
     description = "Wrappers for the framework ScreenSaver on Mac OS X",
     packages = [ "ScreenSaver" ],
     setup_requires = [
-        'pyobjc-core>=2.4',
+        'pyobjc-core>=2.5.0b1',
     ],
     install_requires = [ 
-        'pyobjc-core>=2.4',
-        'pyobjc-framework-Cocoa>=2.4',
+        'pyobjc-core>=2.5.0b1',
+        'pyobjc-framework-Cocoa>=2.5.0b1',
     ],
     ext_modules = [
         Extension('ScreenSaver._inlines',

pyobjc-framework-ScriptingBridge/setup.py

 setup(
     min_os_level='10.5',
     name='pyobjc-framework-ScriptingBridge',
-    version="2.4",
+    version="2.5.0b1",
     description = "Wrappers for the framework ScriptingBridge on Mac OS X",
     packages = [ "ScriptingBridge" ],
     setup_requires = [
-        'pyobjc-core>=2.4',
+        'pyobjc-core>=2.5.0b1',
     ],
     install_requires = [ 
-        'pyobjc-core>=2.4',
-        'pyobjc-framework-Cocoa>=2.4',
+        'pyobjc-core>=2.5.0b1',
+        'pyobjc-framework-Cocoa>=2.5.0b1',
     ],
 )

pyobjc-framework-SearchKit/setup.py

 setup(
     min_os_level='10.5',
     name='pyobjc-framework-SearchKit',
-    version="2.4",
+    version="2.5.0b1",
     description = "Wrappers for the framework SearchKit on Mac OS X",
     packages = [ "SearchKit" ],
     setup_requires = [
-        'pyobjc-core>=2.4',
+        'pyobjc-core>=2.5.0b1',
     ],
     install_requires = [ 
-        'pyobjc-core>=2.4',
-        'pyobjc-framework-Cocoa>=2.4',
+        'pyobjc-core>=2.5.0b1',
+        'pyobjc-framework-Cocoa>=2.5.0b1',
     ],
 )

pyobjc-framework-ServerNotification/setup.py

 setup(
     min_os_level='10.6',
     name='pyobjc-framework-ServerNotification',
-    version="2.4",
+    version="2.5.0b1",
     description = "Wrappers for the framework ServerNotification on Mac OS X",
     packages = [ "ServerNotification" ],
     setup_requires = [
-        'pyobjc-core>=2.4',
+        'pyobjc-core>=2.5.0b1',
     ],
     install_requires = [ 
-        'pyobjc-core>=2.4',
-        'pyobjc-framework-Cocoa>=2.4',
+        'pyobjc-core>=2.5.0b1',
+        'pyobjc-framework-Cocoa>=2.5.0b1',
     ],
 )

pyobjc-framework-ServiceManagement/setup.py

 setup(
     min_os_level='10.6',
     name='pyobjc-framework-ServiceManagement',
-    version="2.4",
+    version="2.5.0b1",
     description = "Wrappers for the framework ServiceManagement on Mac OS X",
     packages = [ "ServiceManagement" ],
     setup_requires = [
-        'pyobjc-core>=2.4',
+        'pyobjc-core>=2.5.0b1',
     ],
     install_requires = [ 
-        'pyobjc-core>=2.4',
-        'pyobjc-framework-Cocoa>=2.4',
+        'pyobjc-core>=2.5.0b1',
+        'pyobjc-framework-Cocoa>=2.5.0b1',
     ],
 )

pyobjc-framework-Social/setup.py

 
 setup(
     name='pyobjc-framework-Social',
-    version="2.4",
+    version="2.5.0b1",
     description = "Wrappers for the framework Accounts on Mac OS X",
     packages = [ "Social" ],
     setup_requires = [
-        'pyobjc-core>=2.4',
+        'pyobjc-core>=2.5.0b1',
     ],
     install_requires = [ 
-        'pyobjc-core>=2.4',
-        'pyobjc-framework-Cocoa>=2.4',
+        'pyobjc-core>=2.5.0b1',
+        'pyobjc-framework-Cocoa>=2.5.0b1',
     ],
     min_os_level="10.8",
 )

pyobjc-framework-SyncServices/setup.py

 
 setup(
     name='pyobjc-framework-SyncServices',
-    version="2.4",
+    version="2.5.0b1",
     description = "Wrappers for the framework SyncServices on Mac OS X",
     packages = [ "SyncServices" ],
     setup_requires = [
-        'pyobjc-core>=2.4',
+        'pyobjc-core>=2.5.0b1',
     ],
     install_requires = [ 
-        'pyobjc-core>=2.4',
-        'pyobjc-framework-Cocoa>=2.4',
-        'pyobjc-framework-CoreData>=2.4',
+        'pyobjc-core>=2.5.0b1',
+        'pyobjc-framework-Cocoa>=2.5.0b1',
+        'pyobjc-framework-CoreData>=2.5.0b1',
     ],
 )

pyobjc-framework-SystemConfiguration/setup.py

 
 setup(
     name='pyobjc-framework-SystemConfiguration',
-    version="2.4",
+    version="2.5.0b1",
     description = "Wrappers for the framework SystemConfiguration on Mac OS X",
     packages = [ "SystemConfiguration" ],
     setup_requires = [
-        'pyobjc-core>=2.4',
+        'pyobjc-core>=2.5.0b1',
     ],
     install_requires = [ 
-        'pyobjc-core>=2.4',
-        'pyobjc-framework-Cocoa>=2.4',
+        'pyobjc-core>=2.5.0b1',
+        'pyobjc-framework-Cocoa>=2.5.0b1',
     ],
     ext_modules = [
         Extension('SystemConfiguration._manual',

pyobjc-framework-WebKit/setup.py

 
 setup(
     name='pyobjc-framework-WebKit',
-    version="2.4",
+    version="2.5.0b1",
     description = "Wrappers for the framework WebKit on Mac OS X",
     packages = [ "WebKit", "JavaScriptCore" ],
     setup_requires = [
-        'pyobjc-core>=2.4',
+        'pyobjc-core>=2.5.0b1',
     ],
     install_requires = [ 
-        'pyobjc-core>=2.4',
-        'pyobjc-framework-Cocoa>=2.4',
+        'pyobjc-core>=2.5.0b1',
+        'pyobjc-framework-Cocoa>=2.5.0b1',
     ],
 )

pyobjc-framework-XgridFoundation/setup.py

 setup(
     max_os_level='10.7',
     name='pyobjc-framework-XgridFoundation',
-    version="2.4",
+    version="2.5.0b1",
     description = "Wrappers for the framework XgridFoundation on Mac OS X",
     packages = [ "XgridFoundation" ],
     setup_requires = [
-        'pyobjc-core>=2.4',
+        'pyobjc-core>=2.5.0b1',
     ],
     install_requires = [ 
-        'pyobjc-core>=2.4',
-        'pyobjc-framework-Cocoa>=2.4',
+        'pyobjc-core>=2.5.0b1',
+        'pyobjc-framework-Cocoa>=2.5.0b1',
     ],
 )
 
 import os
 
-VERSION="2.4"
+VERSION="2.5.0b1"
 
 # Note 1: the requires list is split into a number
 # of lists because not all framework wrappers can
Tip: Filter by directory path e.g. /media app.js to search for public/media/app.js.
Tip: Use camelCasing e.g. ProjME to search for ProjectModifiedEvent.java.
Tip: Filter by extension type e.g. /repo .js to search for all .js files in the /repo directory.
Tip: Separate your search with spaces e.g. /ssh pom.xml to search for src/ssh/pom.xml.
Tip: Use ↑ and ↓ arrow keys to navigate and return to view the file.
Tip: You can also navigate files with Ctrl+j (next) and Ctrl+k (previous) and view the file with Ctrl+o.
Tip: You can also navigate files with Alt+j (next) and Alt+k (previous) and view the file with Alt+o.