1. Ronald Oussoren
  2. pyobjc

Commits

Ronald Oussoren  committed 9768fb1

Try to solve installation order problems

  • Participants
  • Parent commits c954631
  • Branches default

Comments (0)

Files changed (35)

File pyobjc-framework-AddressBook/setup.py

View file
     version="2.4a0",
     description = "Wrappers for the framework AddressBook on Mac OS X",
     packages = [ "AddressBook" ],
+    setup_requires = [
+        'pyobjc-core>=2.4a0',
+    ],
     install_requires = [ 
         'pyobjc-core>=2.4a0',
         'pyobjc-framework-Cocoa>=2.4a0',

File pyobjc-framework-AppleScriptKit/setup.py

View file
     version="2.4a0",
     description = "Wrappers for the framework AppleScriptKit on Mac OS X",
     packages = [ "AppleScriptKit" ],
+    setup_requires = [
+        'pyobjc-core>=2.4a0',
+    ],
     install_requires = [ 
         'pyobjc-core>=2.4a0',
         'pyobjc-framework-Cocoa>=2.4a0',

File pyobjc-framework-AppleScriptObjC/setup.py

View file
     version="2.4a0",
     description = "Wrappers for the framework AppleScriptObjC on Mac OS X",
     packages = [ "AppleScriptObjC" ],
+    setup_requires = [
+        'pyobjc-core>=2.4a0',
+    ],
     install_requires = [ 
         'pyobjc-core>=2.4a0',
         'pyobjc-framework-Cocoa>=2.4a0',

File pyobjc-framework-Automator/setup.py

View file
     version="2.4a0",
     description = "Wrappers for the framework Automator on Mac OS X",
     packages = [ "Automator" ],
+    setup_requires = [
+        'pyobjc-core>=2.4a0',
+    ],
     install_requires = [ 
         'pyobjc-core>=2.4a0',
         'pyobjc-framework-Cocoa>=2.4a0',

File pyobjc-framework-CFNetwork/setup.py

View file
     version="2.4a0",
     description = "Wrappers for the framework CFNetwork on Mac OS X",
     packages = [ "CFNetwork" ],
+    setup_requires = [
+        'pyobjc-core>=2.4a0',
+    ],
     install_requires = [ 
         'pyobjc-core>=2.4a0',
         'pyobjc-framework-Cocoa>=2.4a0',

File pyobjc-framework-CalendarStore/setup.py

View file
     version="2.4a0",
     description = "Wrappers for the framework CalendarStore on Mac OS X",
     packages = [ "CalendarStore" ],
+    setup_requires = [
+        'pyobjc-core>=2.4a0',
+    ],
     install_requires = [ 
         'pyobjc-core>=2.4a0',
         'pyobjc-framework-Cocoa>=2.4a0',

File pyobjc-framework-Cocoa/setup.py

View file
     description = "Wrappers for the Cocoa frameworks on Mac OS X",
     packages = [ "Cocoa", "CoreFoundation", "Foundation", "AppKit", "PyObjCTools" ],
     namespace_packages = ['PyObjCTools'],
+    setup_requires = [
+        'pyobjc-core>=2.4a0',
+    ],
     install_requires = [ 
         'pyobjc-core>=2.4a0',
     ],

File pyobjc-framework-Collaboration/setup.py

View file
     version="2.4a0",
     description = "Wrappers for the framework Collaboration on Mac OS X",
     packages = [ "Collaboration" ],
+    setup_requires = [
+        'pyobjc-core>=2.4a0',
+    ],
     install_requires = [ 
         'pyobjc-core>=2.4a0',
         'pyobjc-framework-Cocoa>=2.4a0',

File pyobjc-framework-CoreData/setup.py

View file
     version="2.4a0",
     description = "Wrappers for the framework CoreData on Mac OS X",
     packages = [ "CoreData" ],
+    setup_requires = [
+        'pyobjc-core>=2.4a0',
+    ],
     install_requires = [ 
         'pyobjc-core>=2.4a0',
         'pyobjc-framework-Cocoa>=2.4a0',

File pyobjc-framework-CoreLocation/setup.py

View file
     version="2.4a0",
     description = "Wrappers for the framework CoreLocation on Mac OS X",
     packages = [ "CoreLocation" ],
+    setup_requires = [
+        'pyobjc-core>=2.4a0',
+    ],
     install_requires = [ 
         'pyobjc-core>=2.4a0',
         'pyobjc-framework-Cocoa>=2.4a0',

File pyobjc-framework-CoreText/setup.py

View file
                 extra_link_args=['-framework', 'CoreServices'],
             ),
     ],
+    setup_requires = [
+        'pyobjc-core>=2.4a0',
+    ],
     install_requires = [ 
         'pyobjc-core>=2.4a0',
         'pyobjc-framework-Cocoa>=2.4a0',

File pyobjc-framework-DictionaryServices/setup.py

View file
     version="2.4a0",
     description = "Wrappers for the framework DictionaryServices on Mac OS X",
     packages = [ "DictionaryServices" ],
+    setup_requires = [
+        'pyobjc-core>=2.4a0',
+    ],
     install_requires = [ 
         'pyobjc-core>=2.4a0',
         'pyobjc-framework-Cocoa>=2.4a0',

File pyobjc-framework-ExceptionHandling/setup.py

View file
     description = "Wrappers for the framework ExceptionHandling on Mac OS X",
     packages = [ "PyObjCTools", "ExceptionHandling" ],
     namespace_packages = [ "PyObjCTools" ],
+    setup_requires = [
+        'pyobjc-core>=2.4a0',
+    ],
     install_requires = [ 
         'pyobjc-core>=2.4a0',
         'pyobjc-framework-Cocoa>=2.4a0',

File pyobjc-framework-FSEvents/setup.py

View file
     version="2.4a0",
     description = "Wrappers for the framework FSEvents on Mac OS X",
     packages = [ "FSEvents" ],
+    setup_requires = [
+        'pyobjc-core>=2.4a0',
+    ],
     install_requires = [ 
         'pyobjc-core>=2.4a0',
         'pyobjc-framework-Cocoa>=2.4a0',

File pyobjc-framework-InputMethodKit/setup.py

View file
     version="2.4a0",
     description = "Wrappers for the framework InputMethodKit on Mac OS X",
     packages = [ "InputMethodKit" ],
+    setup_requires = [
+        'pyobjc-core>=2.4a0',
+    ],
     install_requires = [ 
         'pyobjc-core>=2.4a0',
         'pyobjc-framework-Cocoa>=2.4a0',

File pyobjc-framework-InstallerPlugins/setup.py

View file
     version="2.4a0",
     description = "Wrappers for the framework InstallerPlugins on Mac OS X",
     packages = [ "InstallerPlugins" ],
+    setup_requires = [
+        'pyobjc-core>=2.4a0',
+    ],
     install_requires = [ 
         'pyobjc-core>=2.4a0',
         'pyobjc-framework-Cocoa>=2.4a0',

File pyobjc-framework-InstantMessage/setup.py

View file
     version="2.4a0",
     description = "Wrappers for the framework InstantMessage on Mac OS X",
     packages = [ "InstantMessage" ],
+    setup_requires = [
+        'pyobjc-core>=2.4a0',
+    ],
     install_requires = [ 
         'pyobjc-core>=2.4a0',
         'pyobjc-framework-Cocoa>=2.4a0',

File pyobjc-framework-InterfaceBuilderKit/setup.py

View file
     version="2.4a0",
     description = "Wrappers for the framework InterfaceBuilderKit on Mac OS X",
     packages = [ "InterfaceBuilderKit" ],
+    setup_requires = [
+        'pyobjc-core>=2.4a0',
+    ],
     install_requires = [ 
         'pyobjc-core>=2.4a0',
         'pyobjc-framework-Cocoa>=2.4a0',

File pyobjc-framework-LatentSemanticMapping/setup.py

View file
     version="2.4a0",
     description = "Wrappers for the framework LatentSemanticMapping on Mac OS X",
     packages = [ "LatentSemanticMapping" ],
+    setup_requires = [
+        'pyobjc-core>=2.4a0',
+    ],
     install_requires = [ 
         'pyobjc-core>=2.4a0',
         'pyobjc-framework-Cocoa>=2.4a0',

File pyobjc-framework-LaunchServices/setup.py

View file
     version="2.4a0",
     description = "Wrappers for the framework LaunchServices on Mac OS X",
     packages = [ "LaunchServices" ],
+    setup_requires = [
+        'pyobjc-core>=2.4a0',
+    ],
     install_requires = [ 
         'pyobjc-core>=2.4a0',
         'pyobjc-framework-Cocoa>=2.4a0',

File pyobjc-framework-Message/setup.py

View file
     version="2.4a0",
     description = "Wrappers for the framework Message on Mac OS X",
     packages = [ "Message" ],
+    setup_requires = [
+        'pyobjc-core>=2.4a0',
+    ],
     install_requires = [ 
         'pyobjc-core>=2.4a0',
         'pyobjc-framework-Cocoa>=2.4a0',

File pyobjc-framework-OpenDirectory/setup.py

View file
     version="2.4a0",
     description = "Wrappers for the framework OpenDirectory on Mac OS X",
     packages = [ "OpenDirectory", "CFOpenDirectory" ],
+    setup_requires = [
+        'pyobjc-core>=2.4a0',
+    ],
     install_requires = [ 
         'pyobjc-core>=2.4a0',
         'pyobjc-framework-Cocoa>=2.4a0',

File pyobjc-framework-PreferencePanes/setup.py

View file
     version="2.4a0",
     description = "Wrappers for the framework PreferencePanes on Mac OS X",
     packages = [ "PreferencePanes" ],
+    setup_requires = [
+        'pyobjc-core>=2.4a0',
+    ],
     install_requires = [ 
         'pyobjc-core>=2.4a0',
         'pyobjc-framework-Cocoa>=2.4a0',

File pyobjc-framework-PubSub/setup.py

View file
     version="2.4a0",
     description = "Wrappers for the framework PubSub on Mac OS X",
     packages = [ "PubSub" ],
+    setup_requires = [
+        'pyobjc-core>=2.4a0',
+    ],
     install_requires = [ 
         'pyobjc-core>=2.4a0',
         'pyobjc-framework-Cocoa>=2.4a0',

File pyobjc-framework-QTKit/setup.py

View file
     version="2.4a0",
     description = "Wrappers for the framework QTKit on Mac OS X",
     packages = [ "QTKit" ],
+    setup_requires = [
+        'pyobjc-core>=2.4a0',
+    ],
     install_requires = [ 
         'pyobjc-core>=2.4a0',
         'pyobjc-framework-Cocoa>=2.4a0',

File pyobjc-framework-Quartz/setup.py

View file
     version="2.4a0",
     description = "Wrappers for the Quartz frameworks on Mac OS X",
     packages = [ "Quartz" ] + subpackages,
+    setup_requires = [
+        'pyobjc-core>=2.4a0',
+    ],
     install_requires = [ 
         'pyobjc-core>=2.4a0',
         'pyobjc-framework-Cocoa>=2.4a0',

File pyobjc-framework-ScreenSaver/setup.py

View file
     version="2.4a0",
     description = "Wrappers for the framework ScreenSaver on Mac OS X",
     packages = [ "ScreenSaver" ],
+    setup_requires = [
+        'pyobjc-core>=2.4a0',
+    ],
     install_requires = [ 
         'pyobjc-core>=2.4a0',
         'pyobjc-framework-Cocoa>=2.4a0',

File pyobjc-framework-ScriptingBridge/setup.py

View file
     version="2.4a0",
     description = "Wrappers for the framework ScriptingBridge on Mac OS X",
     packages = [ "ScriptingBridge" ],
+    setup_requires = [
+        'pyobjc-core>=2.4a0',
+    ],
     install_requires = [ 
         'pyobjc-core>=2.4a0',
         'pyobjc-framework-Cocoa>=2.4a0',

File pyobjc-framework-SearchKit/setup.py

View file
     version="2.4a0",
     description = "Wrappers for the framework SearchKit on Mac OS X",
     packages = [ "SearchKit" ],
+    setup_requires = [
+        'pyobjc-core>=2.4a0',
+    ],
     install_requires = [ 
         'pyobjc-core>=2.4a0',
         'pyobjc-framework-Cocoa>=2.4a0',

File pyobjc-framework-ServerNotification/setup.py

View file
     version="2.4a0",
     description = "Wrappers for the framework ServerNotification on Mac OS X",
     packages = [ "ServerNotification" ],
+    setup_requires = [
+        'pyobjc-core>=2.4a0',
+    ],
     install_requires = [ 
         'pyobjc-core>=2.4a0',
         'pyobjc-framework-Cocoa>=2.4a0',

File pyobjc-framework-ServiceManagement/setup.py

View file
     version="2.4a0",
     description = "Wrappers for the framework ServiceManagement on Mac OS X",
     packages = [ "ServiceManagement" ],
+    setup_requires = [
+        'pyobjc-core>=2.4a0',
+    ],
     install_requires = [ 
         'pyobjc-core>=2.4a0',
         'pyobjc-framework-Cocoa>=2.4a0',

File pyobjc-framework-SyncServices/setup.py

View file
     version="2.4a0",
     description = "Wrappers for the framework SyncServices on Mac OS X",
     packages = [ "SyncServices" ],
+    setup_requires = [
+        'pyobjc-core>=2.4a0',
+    ],
     install_requires = [ 
         'pyobjc-core>=2.4a0',
         'pyobjc-framework-Cocoa>=2.4a0',

File pyobjc-framework-SystemConfiguration/setup.py

View file
     version="2.4a0",
     description = "Wrappers for the framework SystemConfiguration on Mac OS X",
     packages = [ "SystemConfiguration" ],
+    setup_requires = [
+        'pyobjc-core>=2.4a0',
+    ],
     install_requires = [ 
         'pyobjc-core>=2.4a0',
         'pyobjc-framework-Cocoa>=2.4a0',

File pyobjc-framework-WebKit/setup.py

View file
     version="2.4a0",
     description = "Wrappers for the framework WebKit on Mac OS X",
     packages = [ "WebKit", "JavaScriptCore" ],
+    setup_requires = [
+        'pyobjc-core>=2.4a0',
+    ],
     install_requires = [ 
         'pyobjc-core>=2.4a0',
         'pyobjc-framework-Cocoa>=2.4a0',

File pyobjc-framework-XgridFoundation/setup.py

View file
     version="2.4a0",
     description = "Wrappers for the framework XgridFoundation on Mac OS X",
     packages = [ "XgridFoundation" ],
+    setup_requires = [
+        'pyobjc-core>=2.4a0',
+    ],
     install_requires = [ 
         'pyobjc-core>=2.4a0',
         'pyobjc-framework-Cocoa>=2.4a0',