Source

pyobjc / pyobjc-core / setup.py

The branch 'pyobjc-2.5.x' does not exist.
Diff from to

File pyobjc-core/setup.py

 # (issue 123 in the distribute tracker)
 class my_egg_info (egg_info.egg_info):
     def run(self):
-        egg_info.egg_info.run(self)
+        self.mkpath(self.egg_info)
 
         for hdr in ("pyobjc-compat.h", "pyobjc-api.h"):
             fn = os.path.join("include", hdr)
 
             write_header(self, fn, os.path.join(self.egg_info, fn))
 
+        egg_info.egg_info.run(self)
+
+
 if sys.version_info[0] == 3:
     # FIXME: add custom test command that does the work.
     # - Patch sys.path