Source

pyobjc / Scripts / buildpkg.py

The branch 'pyobjc-ancient' does not exist.
Author Commit Message Labels Comments Date
Ronald Oussoren
- Check output from Scripts/find-raw-pointers.py, and fix issues - Rename objc.Accessor to objc.accessor. objc.Accessor still exists, to but generates a warning. - Move all extension modules to toplevel for consistency, and remove leftover extension modules from older releases when installing. - Add a note about Cocoa Bindings to the documentation. - Sync MPCompat with current Python version - Some Python2.2/Jaguar related fixes - Fix struct-wrapper (t…
Branches
pyobjc-ancient
Ronald Oussoren
- Give a more usefull error message when a method implementation runs of the end of the function - Recreate HTML files - Create seperate directories for the 10.2 and 10.3 installer - Version is now 1.1a0 - Add wrapper for SecurityInterface (Panther) This is not very usefull, but it is an Apple defined Objective-C framework. - Make CodeGen scripts smart enough to detect enums in SecurityInterface
Branches
pyobjc-ancient
Ronald Oussoren
- detab the CodeGenerator scripts - add some missing files - make sure buildpkg.py works with the newly added InstallationCheck (untested)
Branches
pyobjc-ancient
Ronald Oussoren
- Merge buildpkg.py from Python 2.3 CVS, needed for working postinstall scripts - The generated package is named PyObjC.pkg instead of PyObjC-%(version)s.pkg, hopefully makes future postinstall scripts that move files around unnecessary - Add post_install and post_upgrade script (with same contents) that remove the PyObjC related modules/packages from the site-package directory: Needed for clean upgrades from PyObjC 0.8 installations.
Branches
pyobjc-ancient
Bill Bumgarner
Changes to packaging and templates; 0.8 release candidate.
Branches
pyobjc-ancient
Ronald Oussoren
Added a script to build a distribution: - pyobjc-X.Y.Z.tar.gz containing the sources - pyobjc-X.Y.Z.pkg containing an installer
Branches
pyobjc-ancient