Issues

Issue #33 resolved

Error when using easy-install to sintall pyobjc

Anonymous created an issue

After trying to install with "easy-install -U pyobjc" I get this error

error: Setup script exited with error: This distribution is only supported on MacOSX versions 10.5 upto and including 10.6

I am running a 10.7.5 version of MacOSX.

Comments (4)

  1. Ronald Oussoren repo owner

    Thanks for the report. The "pyobjc" helper project tries to install the interface builder bindings on OSX 10.7, but those aren't supported there.

    I've fixed this in the repository and the fix will be in the next release.

  2. Erik Allik

    The next release is when? It's still not possible to install pyobjc on OS X 10.7.

    P.S. It looks like you already have the 2.5 version here, but not on PyPI.

  3. Ronald Oussoren repo owner

    My current plan is to release 2.5.1 in the upcoming weekend. Until it should be possible to install by creating a checkout of the pyobjc repository (pyobjc-2.5.x branch) and run the "install.py" script in the root of the repository.

    The 2.5 release got tagged but isn't on PyPI because I ran out of time, and in the mean time a couple of bugs have been fixed which means I won't bother to actually push 2.5 to PyPI.

  4. Log in to comment