Issues

Issue #79 duplicate

PyObjC easy install error on Mac OS X 10.8.5

rhys5678
created an issue

So I'm building a game on Python and need to use Interface Builder in XCode for my GUI, with PyObjC bridging it. But when I attempt to install via Terminal I get this error:

sh-3.2# easy_install -U pyobjc Searching for pyobjc Reading http://pypi.python.org/simple/pyobjc/ Best match: pyobjc 2.5.1 Downloading https://pypi.python.org/packages/source/p/pyobjc/pyobjc-2.5.1.tar.gz#md5=f242cff4a25ce397bb381c21a35db885 Processing pyobjc-2.5.1.tar.gz Running pyobjc-2.5.1/setup.py -q bdist_egg --dist-dir /tmp/easy_install-mugUwx/pyobjc-2.5.1/egg-dist-tmp-m5BhAv warning: install_lib: 'build/lib' does not exist -- no Python modules to install

Adding pyobjc 2.5.1 to easy-install.pth file

Installed /Library/Python/2.7/site-packages/pyobjc-2.5.1-py2.7.egg Processing dependencies for pyobjc Searching for pyobjc-framework-Social==2.5.1 Reading http://pypi.python.org/simple/pyobjc-framework-Social/ Best match: pyobjc-framework-Social 2.5.1 Downloading https://pypi.python.org/packages/source/p/pyobjc-framework-Social/pyobjc-framework-Social-2.5.1.tar.gz#md5=1aadaa6d45cfced5d9f243b7d153a2eb Processing pyobjc-framework-Social-2.5.1.tar.gz Running pyobjc-framework-Social-2.5.1/setup.py -q bdist_egg --dist-dir /tmp/easy_install-E6y_II/pyobjc-framework-Social-2.5.1/egg-dist-tmp-Rt_I7P error: Installed distribution pyobjc-core 2.3.2a0 conflicts with requirement pyobjc-core>=2.5.1

Comments (3)

  1. Ronald Oussoren repo owner

    Actually fixing this might require changes to pip and/or easy_install, the error message indicates that dependencies are installed in the wrong order. I can not do anything about that in PyObjC other than specifying the right build and install dependencies.

  2. Log in to comment