Min OS level for CoreBluetooth is 10.10

Issue #105 resolved
Justin Nesselrotte
created an issue

From the current source, it tries to install on 10.9 where CoreBluetooth isn't its own framework, but seems to be a subset of IOBluetooth. I don't know if changing the framework and .m files to use IOBluetooth would fix the issue or not.

Comments (2)

  1. Ronald Oussoren repo owner

    The "current source" seems to mean "the tip of the default branch" is that correct?

    That tip is the in-development version for the next feature release, and contains other bugs as well (amongst others because I'm behind with merging bug fixes from the 3.0.x stable branch).

  2. Ronald Oussoren repo owner

    Good catch. I've updated the code to only install on 10.10 or later because the framework isn't on 10.9 at all.

    The reason I had 10.9 in setup.py is that the framework headers claim that the APIs are available on 10.9 as well, even though they aren't mentioned in headers in the 10.9 SDK

  3. Log in to comment