pyobjc-core install failed once

Issue #136 resolved
Ehsan Azarnasab
created an issue

when I tried to do pip install pyobjc it took a very long time, so I thought it is hung and canceled it. Next I read somewhere I should first install pyobjc-core, but I get this error:

    2015-09-07 12:46:58.858 xcodebuild[74839:465175] [MT] PluginLoading: Required plug-in compatibility UUID 7FDF5C7A-131F-4ABB-9EDC-8C5F8F0B8A90 for plug-in at path '~/Library/Application Support/Developer/Shared/Xcode/Plug-ins/Unity4XC.xcplugin' not present in DVTPlugInCompatibilityUUIDs
    error: Cannot locate a working compiler

It however did install next time when I issued the command and I do not know why. After pyobjc-core installed the rest got installed quickly, but I am not sure if anything is wrong in the setup now. Just wanted to report this here, feel free to close.

Comments (3)

  1. Ronald Oussoren repo owner

    I have no idea what causes this error. The error seems to indicate that the xcodebuild binary is involved somehow, and that shouldn't be used at all when using pip or easy_install to install a package...

    pip install pyobjc takes a long time because this builds pyobjc-core multiple times, as described in issue #21.

  2. Log in to comment