install error on 10.10.5 and pyobjc-core-3.0.4

Issue #139 resolved
Andrew Graham
created an issue

when using

python setup.py install

to install on osx 10.10.4 I get this error

Andrews-iMac:pyobjc-core-3.0.4 Audio$ python setup.py install
running install
running bdist_egg
running egg_info
writing include/pyobjc-compat.h to Lib/pyobjc_core.egg-info/include/pyobjc-compat.h
writing include/pyobjc-api.h to Lib/pyobjc_core.egg-info/include/pyobjc-api.h
writing Lib/pyobjc_core.egg-info/PKG-INFO
writing namespace_packages to Lib/pyobjc_core.egg-info/namespace_packages.txt
writing top-level names to Lib/pyobjc_core.egg-info/top_level.txt
writing dependency_links to Lib/pyobjc_core.egg-info/dependency_links.txt
reading manifest file 'Lib/pyobjc_core.egg-info/SOURCES.txt'
reading manifest template 'MANIFEST.in'
warning: no directories found matching 'Scripts'
warning: no directories found matching 'setup-lib'
warning: no directories found matching 'source-deps'
warning: no previously-included files matching '*.pyc' found anywhere in distribution
warning: no previously-included files matching '*.pyo' found anywhere in distribution
warning: no previously-included files matching '*.so' found anywhere in distribution
warning: no previously-included files matching '*.dSYM/*' found anywhere in distribution
warning: no previously-included files matching '*.dSYM' found anywhere in distribution
warning: no previously-included files matching '__pycache__' found anywhere in distribution
writing manifest file 'Lib/pyobjc_core.egg-info/SOURCES.txt'
installing library code to build/bdist.macosx-10.5-fat/egg
running install_lib
running build_py
Overriding build_packages to copy PyObjCTest
running build_ext
error: Cannot locate a working compiler

I've been reading about this issue for days, it seems a lot of people think its fixed with v3 but I have not had any success.

I have installed Xcode 7 and Command_Line_Tools_OS_X_10.10_for_Xcode_7

if anyone has any pointers it would be great to hear!

Comments (2)

  1. Log in to comment