error code -9 with pip install on OSX 10.11.1

Issue #141 closed
Cameron Taggart created an issue

I'm having a tough time figuring out what this installation error means. Any ideas?

Camerons-iMac:w3af cameron$ sudo -H pip install pyobjc-framework-WebKit --verbose
Collecting pyobjc-framework-WebKit
  Getting page https://pypi.python.org/simple/pyobjc-framework-webkit/
  Starting new HTTPS connection (1): pypi.python.org
  "GET /simple/pyobjc-framework-webkit/ HTTP/1.1" 200 648
  1 location(s) to search for versions of pyobjc-framework-WebKit:
  * https://pypi.python.org/simple/pyobjc-framework-webkit/
  Getting page https://pypi.python.org/simple/pyobjc-framework-webkit/
  Analyzing links from page https://pypi.python.org/simple/pyobjc-framework-webkit/
    Skipping link https://pypi.python.org/packages/2.6/p/pyobjc-framework-WebKit/pyobjc_framework_WebKit-2.2-py2.6.egg#md5=7a5b18e960be44fd314b0f05afc1408f (from https://pypi.python.org/simple/pyobjc-framework-webkit/); unsupported archive format: .egg
    Skipping link https://pypi.python.org/packages/2.6/p/pyobjc-framework-WebKit/pyobjc_framework_WebKit-2.2b2-py2.6.egg#md5=052694f776f503f3d0072829efa20f65 (from https://pypi.python.org/simple/pyobjc-framework-webkit/); unsupported archive format: .egg
    Skipping link https://pypi.python.org/packages/2.6/p/pyobjc-framework-WebKit/pyobjc_framework_WebKit-2.3-py2.6.egg#md5=c2222ba3892c65537fb3ea2e02196c80 (from https://pypi.python.org/simple/pyobjc-framework-webkit/); unsupported archive format: .egg
    Skipping link https://pypi.python.org/packages/2.7/p/pyobjc-framework-WebKit/pyobjc_framework_WebKit-2.3-py2.7.egg#md5=1f9a34f577fc1f26b1169164ca00a292 (from https://pypi.python.org/simple/pyobjc-framework-webkit/); unsupported archive format: .egg
    Skipping link https://pypi.python.org/packages/3.1/p/pyobjc-framework-WebKit/pyobjc_framework_WebKit-2.3-py3.1.egg#md5=0957ccc1611552ff6be1eee475f82661 (from https://pypi.python.org/simple/pyobjc-framework-webkit/); unsupported archive format: .egg
    Skipping link https://pypi.python.org/packages/3.2/p/pyobjc-framework-WebKit/pyobjc_framework_WebKit-2.3-py3.2.egg#md5=df576f8bd8969f5c55319238c2a1da58 (from https://pypi.python.org/simple/pyobjc-framework-webkit/); unsupported archive format: .egg
    Found link https://pypi.python.org/packages/source/p/pyobjc-framework-WebKit/pyobjc-framework-WebKit-2.2.tar.gz#md5=8ec9201c36394605783432c97fe5015a (from https://pypi.python.org/simple/pyobjc-framework-webkit/), version: 2.2
    Found link https://pypi.python.org/packages/source/p/pyobjc-framework-WebKit/pyobjc-framework-WebKit-2.2b2.tar.gz#md5=6f5fdcc1f6e7699cbfb0c12d844541d7 (from https://pypi.python.org/simple/pyobjc-framework-webkit/), version: 2.2b2
    Found link https://pypi.python.org/packages/source/p/pyobjc-framework-WebKit/pyobjc-framework-WebKit-2.3.tar.gz#md5=a30e90c8a4399c2b6b67e8174bb64db8 (from https://pypi.python.org/simple/pyobjc-framework-webkit/), version: 2.3
    Found link https://pypi.python.org/packages/source/p/pyobjc-framework-WebKit/pyobjc-framework-WebKit-2.4.tar.gz#md5=715f58c4302cf69bcc84d22f796c334b (from https://pypi.python.org/simple/pyobjc-framework-webkit/), version: 2.4
    Found link https://pypi.python.org/packages/source/p/pyobjc-framework-WebKit/pyobjc-framework-WebKit-2.5.1.tar.gz#md5=010578f317c8f3834077df72b8fbb7fd (from https://pypi.python.org/simple/pyobjc-framework-webkit/), version: 2.5.1
    Found link https://pypi.python.org/packages/source/p/pyobjc-framework-WebKit/pyobjc-framework-WebKit-3.0.1.tar.gz#md5=7f62c9fd61d264a7b1d365ddce01921e (from https://pypi.python.org/simple/pyobjc-framework-webkit/), version: 3.0.1
    Found link https://pypi.python.org/packages/source/p/pyobjc-framework-WebKit/pyobjc-framework-WebKit-3.0.3.tar.gz#md5=773f9b09c0360cc315c3623bf4e34fcb (from https://pypi.python.org/simple/pyobjc-framework-webkit/), version: 3.0.3
    Found link https://pypi.python.org/packages/source/p/pyobjc-framework-WebKit/pyobjc-framework-WebKit-3.0.4.tar.gz#md5=0c1501598cbe8a8df22d166405daaa19 (from https://pypi.python.org/simple/pyobjc-framework-webkit/), version: 3.0.4
  Using version 3.0.4 (newest of versions: 3.0.4, 3.0.3, 3.0.1, 2.5.1, 2.4, 2.3, 2.2)
  Using cached pyobjc-framework-WebKit-3.0.4.tar.gz
  Downloading from URL https://pypi.python.org/packages/source/p/pyobjc-framework-WebKit/pyobjc-framework-WebKit-3.0.4.tar.gz#md5=0c1501598cbe8a8df22d166405daaa19 (from https://pypi.python.org/simple/pyobjc-framework-webkit/)
  Running setup.py (path:/private/tmp/pip-build-naZIXw/pyobjc-framework-WebKit/setup.py) egg_info for package pyobjc-framework-WebKit
    Running command python setup.py egg_info
    Complete output from command python setup.py egg_info:

    ----------------------------------------
Cleaning up...
Command "python setup.py egg_info" failed with error code -9 in /private/tmp/pip-build-naZIXw/pyobjc-framework-WebKit
Exception information:
Traceback (most recent call last):
  File "/var/root/Library/Python/2.7/lib/python/site-packages/pip/basecommand.py", line 211, in main
    status = self.run(options, args)
  File "/var/root/Library/Python/2.7/lib/python/site-packages/pip/commands/install.py", line 294, in run
    requirement_set.prepare_files(finder)
  File "/var/root/Library/Python/2.7/lib/python/site-packages/pip/req/req_set.py", line 334, in prepare_files
    functools.partial(self._prepare_file, finder))
  File "/var/root/Library/Python/2.7/lib/python/site-packages/pip/req/req_set.py", line 321, in _walk_req_to_install
    more_reqs = handler(req_to_install)
  File "/var/root/Library/Python/2.7/lib/python/site-packages/pip/req/req_set.py", line 505, in _prepare_file
    abstract_dist.prep_for_dist()
  File "/var/root/Library/Python/2.7/lib/python/site-packages/pip/req/req_set.py", line 123, in prep_for_dist
    self.req_to_install.run_egg_info()
  File "/var/root/Library/Python/2.7/lib/python/site-packages/pip/req/req_install.py", line 410, in run_egg_info
    command_desc='python setup.py egg_info')
  File "/var/root/Library/Python/2.7/lib/python/site-packages/pip/utils/__init__.py", line 733, in call_subprocess
    % (command_desc, proc.returncode, cwd))
InstallationError: Command "python setup.py egg_info" failed with error code -9 in /private/tmp/pip-build-naZIXw/pyobjc-framework-WebKit
Camerons-iMac:w3af cameron$ 

MacPorts Python 2.7 is active.

Camerons-iMac:w3af cameron$ port select --list python
Available versions for python:
    none
    python26-apple
    python27 (active)
    python27-apple
    python35
Camerons-iMac:w3af cameron$ which pip
/opt/local/bin/pip
Camerons-iMac:w3af cameron$ port select --list pip
Available versions for pip:
    none
    pip27 (active)
    pip35

Comments (4)

  1. Log in to comment