Support of PyPy would be nice

Issue #147 new
Ronald Oussoren
repo owner created an issue

It would be nice to support PyPy.

As noted in #146 pyobjc-core currently does not build when using PyPy (5.0.1 at the time).

There are a number of symbols in the CPython API that aren't present in PyPy. Some of those aren't strictly necessary and could be avoided by tweaking PyObjC's internal API.

Other symbols require more work and might require changes to PyPy. Some of the issues can be avoided by moving some logic from C code to Python code (such as the logic that converts Python callables to objc.selector objects).

Comments (2)

  1. Log in to comment