pyobjc fails to install on osx 10.11.4

Issue #150 resolved
Gary Church
created an issue

Hello, I'm trying to install pyobjc on OSX 10.11.4 but am having an issue.

I first tried installing with pip.

Using pip, pyobjc-core installed fine but pyobjc did not. Running 'pip install pyobjc', I got 3 errors:

Failed building wheel for pyobjc-framework-MapKit Failed building wheel for pyobjc-framework-Quartz Failed building wheel for pyobjc-framework-CoreLocation

and at the end of the failed compile I got:

Command "/Users/gary/anaconda/envs/py3k/bin/python -u -c "import setuptools, tokenize;file='/private/var/folders/sr/njmfs9h101gf0k6h8qykh26m0000gn/T/pip-build-j248o_nm/pyobjc-framework-CoreLocation/setup.py';exec(compile(getattr(tokenize, 'open', open)(file).read().replace('\r\n', '\n'), file, 'exec'))" install --record /var/folders/sr/njmfs9h101gf0k6h8qykh26m0000gn/T/pip-3dg2_5x2-record/install-record.txt --single-version-externally-managed --compile" failed with error code 1 in /private/var/folders/sr/njmfs9h101gf0k6h8qykh26m0000gn/T/pip-build-j248o_nm/pyobjc-framework-CoreLocation/

I then tried manually installing pyobjc by installing (in order): pyobjc-core-3.1.1 pyobjc-framework-Cocoa-3.1.1 pyobjc-framework-Quartz-3.1.1

by running python3 setup.py install from each directory. pyobjc-core and pyobjc-framework-Cocoa seem to have installed without problem. However, when I tried installing pyobjc-framework-Quartz, I got the following:

building 'Quartz.ImageKit._imagekit' extension gcc -fno-strict-aliasing -Wsign-compare -Wunreachable-code -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -I/Users/gary/anaconda/envs/py3k/include -arch x86_64 -Ibuild/temp.macosx-10.5-x86_64-3.5/pyobjc-include -I/Users/gary/anaconda/envs/py3k/include/python3.5m -c Modules/_imagekit.m -o build/temp.macosx-10.5-x86_64-3.5/Modules/_imagekit.o -DPyObjC_BUILD_RELEASE=1011 -isysroot / In file included from Modules/_imagekit.m:9: Modules/_ImageKit_protocols.m:11:28: error: cannot find protocol declaration for 'IKCameraDeviceViewDelegate' p = PyObjC_IdToPython(@Haiyang SI(IKCameraDeviceViewDelegate)); Py_XDECREF(p); ^ Modules/_ImageKit_protocols.m:12:28: error: cannot find protocol declaration for 'IKDeviceBrowserViewDelegate' p = PyObjC_IdToPython(@Haiyang SI(IKDeviceBrowserViewDelegate)); Py_XD... ^ Modules/_ImageKit_protocols.m:13:28: error: cannot find protocol declaration for 'IKScannerDeviceViewDelegate' p = PyObjC_IdToPython(@Haiyang SI(IKScannerDeviceViewDelegate)); Py_XD... ^ 3 errors generated. error: command 'gcc' failed with exit status 1

Any ideas what my problems might be and any ideas for a fix?

Thanks much, Gary

Comments (4)

  1. Log in to comment