Issues with Pasteboard and tmux on Sierra

Issue #166 wontfix
myyc
created an issue

Edit: leaving the comment below for historical reasons. Turns out NSPasteboard doesn't work within tmux on Sierra. I tried it out on another machine with the same versions of everything but OSX and it worked as usual. Will report the bug to tmux too.

Hey, not sure if this has to do with the fact that the Swift method is now called NSPasteboard.general. I tried hacking the name into the metadata but it didn't fix it.

By "doesn't work" I mean that NSPasteboard.generalPasteboard() returns None

Comments (5)

  1. Ronald Oussoren repo owner

    Am I correct when I write that NSPasteboard.generalPasteboard() returns None while running inside a tmux session, but returns a pasteboard when running outside of tmux?

    How did you install tmux? Using Homebrew or some other method?

    BTW. the method seems to work fine using /usr/bin/screen.

    W.r.t. the name of the method in Swift: that's not relevant for PyObjC, it always uses the Objective-C names.

  2. Ronald Oussoren repo owner

    I'm closing this issue because this isn't a problem with PyObjC.

    I get the same problem with the following Objective-C code:

    #import <Cocoa/Cocoa.h>
    
    int main(void)
    {
    
        NSLog(@"%@",  [NSPasteboard generalPasteboard]);
    }
    
  3. myyc reporter

    I did install via homebrew. Maybe Sierra added a bunch of stuff that doesn't play nicely with tmux. I've encountered related bugs with different software. Thanks for looking into it :)

  4. Log in to comment