pkg_resources.VersionConflict pyobjc-core

Issue #170 wontfix
Milo Spencer-Harper
created an issue

When I run the command "sudo pip install -U pyobjc", as per the documentation, on OS X El Captain 10.11.5 I get the error message:

raise VersionConflict(dist,req) # XXX put more info here

pkg_resources.VersionConflict: (pyobjc-core 2.5.1 (/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/PyObjC), Requirement.parse('pyobjc-core>=3.1.1')) 

Could you help?

Comments (3)

  1. Ronald Oussoren repo owner

    Are you using /usr/bin/python for this? If so: don't upgrade PyObjC in the system install of Python, that might break functionality of the OS. It is better to either use the Python.org installer or virtualenv (or both).

  2. Milo Spencer-Harper reporter

    Thank you. Yes I was using the system install of Python. When I use virtualenv it works fine. However, at the time I was using a third party library that couldn't run inside virtualenv.

  3. Log in to comment