Issues

Issue #48 closed

"easy_install -U pyobjc" failure

Ronald Oussoren
repo owner created an issue

From an e-mail report:

Searching for pyobjc
Reading http://pypi.python.org/simple/pyobjc/
Reading http://pyobjc.sourceforge.net/
Reading http://pyobjc.sourceforge.net/software/index.php
Best match: pyobjc 2.5.1
Processing pyobjc-2.5.1-py2.7.egg
pyobjc 2.5.1 is already the active version in easy-install.pth

Using /Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pyobjc-2.5.1-py2.7.egg
Processing dependencies for pyobjc
Searching for pyobjc-framework-Social==2.5.1
Reading http://pypi.python.org/simple/pyobjc-framework-Social/
Reading http://pyobjc.sourceforge.net
Best match: pyobjc-framework-Social 2.5.1
Downloading http://pypi.python.org/packages/source/p/pyobjc-framework-Social/pyobjc-framework-Social-2.5.1.tar.gz#md5=1aadaa6d45cfced5d9f243b7d153a2eb
Processing pyobjc-framework-Social-2.5.1.tar.gz
Writing /tmp/easy_install-OIZ0CF/pyobjc-framework-Social-2.5.1/setup.cfg
Running pyobjc-framework-Social-2.5.1/setup.py -q bdist_egg --dist-dir /tmp/easy_install-OIZ0CF/pyobjc-framework-Social-2.5.1/egg-dist-tmp-sMndAa
error: Installed distribution pyobjc-core 2.5.0b1 conflicts with requirement pyobjc-core>=2.5.1

This is the output of "easy_install -U" on a machine that was running pyobjc 2.5.0b1 (trying to update to 2.5.1).

The workaround is to manually remove the previous installation.

Comments (2)

  1. Log in to comment