Issues

Issue #89 wontfix

Error when installing PyObjC 2.5.1 on OS X 10.9.3 (Mavericks)

lsfalimis
created an issue
pip install -U pyobjc

returns

Command python setup.py egg_info failed with error code 1 in /private/var/folders/1l/tt74p_z93j9d07418vkyrj6c0000gn/T/pip_build_henry/pyobjc-framework-AddressBook
Storing debug log for failure in /Users/henry/Library/Logs/pip.log

pip.log is here (it's too long to paste here).

Comments (9)

  1. jon holt

    having the same issues:

    iMac with os X 10.9.4 mavericks, clean installed Brew python Xcode 5.1.1 installed command line tools from apple developer pip install pyobjc

    previous clean install on my other machine worked fine with 10.9 and Xcode (? version). I suspect it is the new compiler from Xcode, as everything else is the same.

  2. Will Patera

    I am also getting an error when attempting to install either pyobjc-core or pyobjc on my machine (OSX 10.9.4) clean installed Brew Python 2.7.8 with command line tools 6.0.x for pyobjc 3.0.1

    I have tried installing with simple pip commands as well as the following:

    env CC=clang pip install -U pyobjc-core
    env CC=clang pip install -U pyobjc
    

    Both resulting in the error:

    subprocess.CalledProcessError: Command '['/usr/bin/xcodebuild', '-version', '-sdk', 'macosx', 'Path']' returned non-zero exit status 1
    

    xcodebuild does not exist on my machine because I am using apple command line tools. Perhaps this a brew Python error?

    Any suggestions?

  3. Will Patera

    It appears that the same error occurs with pyobjc 3.0.1 when attempting to install from source

    python install.py
    

    error message:

    subprocess.CalledProcessError: Command '['/usr/bin/xcodebuild', '-version', '-sdk', 'macosx', 'Path']' returned non-zero exit status 1
    Installing 'pyobjc-core' failed (status 1)
    
  4. Will Patera

    On further digging this seems like this might be a Mavericks issue -- see this stackoverflow question

    Good news I installed Xcode (5.1) and was able to pip install pyobjc-core without errors.

    Do you think it would be possible to modify the pyobjc-core setup.py so that one can install pyobjc on Mavericks without XCode but only with command line tools?

    Bad news I was not able to successfully pip install pyobjc exited with the error:

    Could not find any downloads that satisfy the requirement pyobjc-framework-GameKit==3.0.1 (from pyobjc)
    

    I see that this is addressed in this issue - so it will likely be resolved soon I hope.

  5. Log in to comment