failed to install pyobjc 3.0.1 with pip on 10.9.4 with missing pyobjc-framework-GameKit

Issue #92 resolved
Masato Onodera created an issue

Hi,

when I tried to upgrade pyobjc 2.5.1 to 3.0.1 on my OS X 10.9.4 with Xcode 5.1.1 by pip install -U pyobjc, I failed to install it with the following error message.

Downloading/unpacking pyobjc-framework-GameKit==3.0.1 (from pyobjc)
  Could not find any downloads that satisfy the requirement pyobjc-framework-GameKit==3.0.1 (from pyobjc)
Cleaning up...
No distributions at all found for pyobjc-framework-GameKit==3.0.1 (from pyobjc)
Storing debug log for failure in /Users/monodera/.pip/pip.log

Apparently, there is no pyobjc-framework-GameKit in the repository, and pyobjc-framework-GameKit is not uncommented in setup.py in pyobjc 2.5.1.

Comments (19)

  1. Pablo Castillo

    I won't call this a fix, but as a workaround you can try to comment out 'pyobjc-framework-GameKit' entry on setup.py.

  2. Pablo Castillo

    Not that I'm aware. You need to download the source code of pyobj and modify the setup.py file, and then a "python setup.py install" will do the magic.

  3. Masato Onodera reporter

    Thanks. I've tried to do that, but I got errors from some pyobjc components which do not support 10.9... I think I should wait for updates on these packages for 10.9 support.

  4. Ronald Oussoren repo owner

    monodera: what kind of errors do you get on 10.9? PyObjC should work fine on 10.9, the only problem I know of is that there is no metadata for APIs introduced in 10.9.

  5. Denis A Engemann

    Hello folks, any progress on this? I get the same error on 10.8 ... where do I find the GameKit? Why is it included in setup.py?

  6. Ronald Oussoren repo owner

    I intend to push out a new release tonight. GameKit is a framework on OSX 10.9 that isn't wrapped in PyObjC yet but accidentally ended up in the dependency list for pyobjc project.

  7. Denis A Engemann

    @ronaldoussoren it seems there is dozens of frameworks for wihch this problem occurs on 10.8... It seems I can comment out half of setup.py .... any thoughts?

  8. Denis A Engemann

    @ronaldoussoren nevermind + sorry for the noise, was running setup.py directly instead of install.py -- my bad.

  9. Masato Onodera reporter

    With rev:5326:a2cdc24d6e52, I was able to install pyobjc without any problem. Thanks!

    For the previous question about the error I got, it's about 'max_os_level' in setup.py. When max_os_level is set to 10.8 and this component is requested to be installed by the parent setup.py in pyobjc, installation appears to get failed.

  10. Roger Kohler

    When I downloaded the source and updated setup.py and ran python3 setup.py install I got an error:

    Installed /private/var/folders/ln/jb79h0155x3dgzfpxhvcwscr0000gn/T/easy_install-mt58p3vh/pyobjc-framework-ServerNotification-3.0.1/pyobjc_core-3.0.1-py3.4-macosx-10.6-intel.egg error: Setup script exited with error: This distribution is only supported on MacOSX versions 10.6 upto and including 10.8

    and I am running on MacOSx 10.9.4 with python 3.4.1 - what am I missing?

  11. Jose Diaz-Gonzalez

    I made a PR to remove it again. @pablo.adrian.castillo can you either package GameKit or have a pre-commit hook that forces you to check for changes against setup.py before allowing you to commit?

  12. Christopher Tomkins-Tinch

    Any update on this? I ran into it on OSX 10.9.5 with Python 2.7.5, in attempted install using pip.

  13. Kash Karimi

    Still same error on Mavericks. Is it possible GameKit to be made an optional dependency or something? Thanks

  14. Log in to comment