Installation problems with python3 on branch version_2.4.x

Issue #166 invalid
Pablo Oliveira created an issue

Hi,

Install reports Python 3 is needed,

$ python setup.py install
Currently, rpy2 2.4.0dev is only supporting Python 3.

but when using Python3, an encoding error is triggered

$ python3 setup.py install
[...]
   File "setup.py", line 121, in finalize_options
    rversion = get_rversion(r_home)
  File "setup.py", line 177, in get_rversion
    if rversion.startswith(b"WARNING"):
TypeError: startswith first arg must be str or a tuple of str, not bytes

I would like to work on #161. But when running the tests, my system-wide rpy2 package is loaded. Is there a workaround for running the tests without installing ?

Thanks !

Pablo

Comments (3)

  1. Laurent Gautier

    Python 3-only will be for the default branch, which should have been changed to rpy2-2.5.0-dev (now changed). Thanks for the report.

  2. Log in to comment