running RPY2 in arcgis (regression kriging tool)

Issue #189 invalid
Former user created an issue

ok, So I need RPY2 To run the regression kriging toolbox in arcgis 10.1, so I installed RPY2 (eventually), then got errors for r_home, I found how to set that, then got an error for r_user, so I set that (advanced settings-environmental variables), and now I have another error that is stopping rpy2 working-and I can't find any decent info on how to fix it-the script (within arcgis) is just meant to test if rpy2 is running, which it's not...... Here is the error:

Executing: RPiValue C:\Users\ACH-BigDell\Documents\ArcGIS\alt.asc C:\Users\ACH-BigDell\Documents\ArcGIS\n1\IUO Start Time: Wed Apr 16 16:13:48 2014 Running script RPiValue...

Traceback (most recent call last): File "C:\Users\ACH-BigDell\Documents\ArcGIS\ArcGIS_assign_R_pi_to_Raster.py", line 40, in <module> for ii in range ((width/CellWidth)-1): TypeError: range() integer end argument expected, got float.

Failed to execute (RPiValue). Failed at Wed Apr 16 16:14:05 2014 (Elapsed Time: 17.00 seconds)

Comments (1)

  1. Log in to comment