rpy2-2.9.4

Issue #470 resolved
Laurent Gautier created an issue
  • create tag RELEASE_2_9_4
  • build binary wheel for OS X (note: R-3.4 or 3.5 ? R-3.5 introduced internal change in the way object are handled so surprises may happen)
  • test the binary wheel for OS X (run the unit tests)
  • upload the source package and the binary wheel(s) to pypi

Comments (21)

  1. Clemens Brunner

    Building the wheel with R 3.5 worked, but I get a bunch of errors in the tests. 14 errors are "RuntimeError: R must be initialized before instances of GraphicalDevice can be created.", e.g. in /usr/local/lib/python3.6/site-packages/rpy2/rinterface/tests/test_Device.py:22.

    The other error is an "AssertionError: RRuntimeError not raised by <rpy2.rinterface.SexpClosure - Python:0x114c32630 / R:0x7fe5cf135cb0>". Here's the full message:

    ________________________________ SexpClosureTestCase.testClosureenv ________________________________
    
    self = <rpy2.rinterface.tests.test_SexpClosure.SexpClosureTestCase testMethod=testClosureenv>
    
        def testClosureenv(self):
            exp = rinterface.parse("function(x) { x[y] }")
            fun = rinterface.baseenv["eval"](exp)
            vec = rinterface.baseenv["letters"]
    >       self.assertRaises(rinterface.RRuntimeError, fun, vec)
    E       AssertionError: RRuntimeError not raised by <rpy2.rinterface.SexpClosure - Python:0x114c32630 / R:0x7fe5cf135cb0>
    
    /usr/local/lib/python3.6/site-packages/rpy2/rinterface/tests/test_SexpClosure.py:49: AssertionError
    
  2. Laurent Gautier reporter

    Thanks.

    Did you ensure you are at the right branch / revision ?

    hg update -r RELEASE_2_9_4
    

    How are you running the tests ?

  3. Clemens Brunner

    I did a fresh clone followed by hg checkout RELEASE_2_9_4. Then I ran the tests with pytest --pyargs rpy2.

  4. Laurent Gautier reporter

    I am only moving to pytest with the next major release rpy2-3.0.0 ( branch default).

    Use python -m rpy2.tests.

  5. Laurent Gautier reporter

    Thanks. The segfault should only happen with R-3.5. I just thought that may be I know how to make a quick fix (before refactoring for rpy2 3.0.0). Stay tuned.

  6. Laurent Gautier reporter

    @cbrnr

    Issue #471 is finally solved and I have forced the tag RELEASE_2_9_4 to move to that last fix. Let me know if any issue with fetching that updated version, building it, and whether the segfault is also gone on your side. If everything is clear the plan is:

    • delete the build for 2.9.4 attached few comments above
    • attach new build
    • officially release 2.9.4 and push source package and wheel for OS X to pypi.
  7. Clemens Brunner

    I still get the segfault. I normally use git so I'm not sure if I did the update right, but I guess hg pull followed by hg update RELEASE_2_9_4 should work, correct?

  8. Laurent Gautier reporter

    I don't know. I have to force the tag on my side. Do you get anything different with the head of branch version_2.9.x ?

  9. Clemens Brunner

    Wait, I think I forgot to compile the package. It does work now. I confirmed this with 2_9_3, which still gives the segfault.

  10. Laurent Gautier reporter

    I think that I have figured out how to remove the old wheel from the issue.

    Thanks a lot !

    I will normally release rpy2-2.9.4 on pypi tonight.

  11. Log in to comment