pip install dpy2 failed on Mac

Issue #598 wontfix
Andrew Legan created an issue

Unable to install dpy2 on macOS Mojave (10.14.6)

R version: 3.6.1

Python version: 2.7.10

Error message:

Building wheels for collected packages: rpy2

Building wheel for rpy2 (setup.py) ... error

ERROR: Command errored out with exit status 1:

Comments (1)

  1. Laurent Gautier

    The full traceback is likely much longer than that.

    In any case, rpy2 has stopped supporting Python < 3 quite a while ago. It won't even install on Python 2.7.

    Consider installing Python >= 3.6 using homebrew (this is how it is done on Travis CI to test rpy2).

  2. Log in to comment