pip install rpy2 failed on Red Hat Enterprise Linux Server release 6.10

Issue #605 new
Nir Katz created an issue

Python 3.6.8
R 3.5.2
OS Red Hat Enterprise Linux Server release 6.10

When running pip install rpy2 I get the following error:

running build_ext
generating cffi module 'build/temp.linux-x86_64-3.6/_rinterface_cffi_api.c'
creating build/temp.linux-x86_64-3.6
building '_rinterface_cffi_api' extension
creating build/temp.linux-x86_64-3.6/build
creating build/temp.linux-x86_64-3.6/build/temp.linux-x86_64-3.6
gcc -pthread -Wsign-compare -DNDEBUG -g -fwrapv -O3 -Wall -fPIC -DRPY2_RLEN_LONG=True -Irpy2/rinterface_lib/ -I/usr/local/include/python3.6m -c build/temp.linux-x86_64-3.6/_rinterface_cffi_api.c -o build/temp.linux-x86_64-3.6/build/temp.linux-x86_64-3.6/_rinterface_cffi_api.o
In file included from build/temp.linux-x86_64-3.6/_rinterface_cffi_api.c:494:
rpy2/rinterface_lib/R_API_eventloop.h:24: error: redefinition of typedef ‘InputHandler’
rpy2/rinterface_lib/R_API_eventloop.h:6: note: previous declaration of ‘InputHandler’ was here
error: command 'gcc' failed with exit status 1

I get the same error when building the sources of rpy2-3.2.4.

What can be the problem?

Thanks!

Comments (1)

  1. Log in to comment