Issues

Issue #428 invalid

Losing fps in 0.8.0

molul
created an issue

In my game, when I start the demo level, FPS are ~430 (I'm currently only drawing a Tiled map and the hero). Then I move through all the level (~200x40 tiles, being each tile 128x128), and when I come back to the beginning of the level, FPS have dropped down to 330. Good news is that it doesn't repeat (if I move through the map and go back to the beginning again, FPS stay at 330).

I've also tried in 0.7.2 and it doesn't happen. FPS go back to 430.

Steps to reproduce it: 0.- Extract the contents in the zip (a .love and the instructions). 1.- Open the attached .love. Read the instructions if you want to know the whole moveset of the game. 2.- Press Enter until you reach the demo level (Mountain1; forget about Mountain2). Remember the FPS (430 in my case). 3.- Go to the end of the map and come back to the beginning. In my laptop FPS drop to 330.

Comments (4)

  1. molul reporter

    Sorry, I forgot to say that you have to disable vsync. Just go to the options (if you're already playing, press Esc to show the pause menu, then go to Options->Video, then in Vsync move left or right to select "no" and then go down to "Aplly changes" and press enter; finally, press Esc until you leave the menu).

  2. josefnpat
    [spiral]$ cloc .
          58 text files.
          58 unique files.                              
          15 files ignored.
    
    http://cloc.sourceforge.net v 1.53  T=0.5 s (86.0 files/s, 18010.0 lines/s)
    -------------------------------------------------------------------------------
    Language                     files          blank        comment           code
    -------------------------------------------------------------------------------
    Lua                             41           1395           1002           6386
    XML                              2              0              0            222
    -------------------------------------------------------------------------------
    SUM:                            43           1395           1002           6608
    

    There is almost 6.4K lines of code here. There are so many things you could check for here.

    This should not be in the issue tracker unless you can absolutely point to a function that is causing your issue. The issue tracker is not a system to debug your game, it's to handle bugs and feature requests for the love framework. If you're having a problem with the tiled library, take it up with the library developer.

    Your game doesn't even run in a sanitary environment. http://i.imgur.com/TBM1t.png

  3. Bart van Strien

    As josefnpat says, unless you can point us to a specific bug and can tell us how to reproduce it, without having to dig through hundreds (or thousands) of lines of code, it's easier to assume something's wrong in the code ;). Seriously though, if you do manage to trace this down to a bug in the engine, feel free to reopen this ticket with the new info.

  4. molul reporter

    Yes, sorry for the mistake. I'll continue with this issue on the forum. You can actually close it if you want. I'll open a new ticket when I'm sure it's a proper one :)

  5. Log in to comment