It might be cool if all the setters had getters, and all the getters had setters. (e.g.
love.graphics.newParticleSystem could have a default buffer size. I'm not certain what the default value should be though. Maybe 1000?
I'm not sure whether this is a good idea, but perhaps
setGravity could be renamed
setVerticalVelocity, and joined by
And I was wondering whether
setSprite would be better named
setImage. Perhaps "sprite" is the correct term, but it seems slightly incongruous with
isStopped methods would be useful too? I'm not really sure about use cases outside of a particle system demo/editor.
- What if
(min, max)arguments like some other ParticleSystem methods? They're a bit different in that they're about the emitter and not the particles, and also
setLifetimehas the special case of -1 meaning "emit forever".
setParticleLifeseem to be named kind of inconsistently.
And maybe if
count was named
getNumParticles or something it would be more descriptive and consistent? Names not starting with
is/get/set generally seem to be "actions" performed on an object, like
getNum* names are consistent with
love.audio.getNumSources and things in the
love.joystick module, although
love.physics seems to use