Issues

Issue #557 wontfix

renaming love.mouse.isVisible -> love.mouse.getVisible

Anonymous created an issue

i propose to rename love.mouse.isVisible function in love.mouse.getVisible because people don't understand always it's a getter and try to use it as a setter

Comments (2)

  1. Alex Szpakowski

    I believe all LÖVE functions which return a single boolean value have the "is" prefix, e.g. love.graphics.isSupported, love.keyboard.isDown, etc.

    It would be inconsistent with the rest of the API to change love.mouse.isVisible to love.mouse.getVisible.

  2. Log in to comment