Issues

Issue #601 resolved

ParticleSystem setLifetime/setParticleLife naming consistency

hahawoo
created an issue

For the emitter, it's setLifetime, for particles it's setParticleLife, which is slightly inconsistent, which could make it a bit more difficult to remember the names perhaps.

So I'd suggest something like...

  • setLife or setEmitterLife and setParticleLife
  • setLifetime or setEmitterLifetime and setParticleLifetime