Issues

Issue #637 resolved

Renaming "screen" configuration option to "mode"

hahawoo
created an issue

t.screen in love.conf seems to be inconsistent with setMode, perhaps it should be renamed to t.mode?

"screen" is a bit more descriptive than "mode", but the video mode isn't called "screen" elsewhere in the API.

Comments (4)

  1. hahawoo reporter

    Actually maybe I can deal with this being inconsistent. The understandability of setMode is helped by being the window module. And does t.mode = false make sense? But t.screen and setMode are really similar. Trivial semantic details, woo!

  2. hahawoo reporter

    That sounds really good to me, it's consistent with love.window and also maybe it could theoretically hold settings which aren't in setMode but are related to the window.

    Edit: Actually, I'm not sure having settings not related to the display mode would make sense. I was imagining something like t.window.icon = 'icon.png', but then, you could also do something like t.window = false, and you still might want the settings for the icon or things-other-than-the-display-mode, but you might not want to actually create the screen.

  3. Log in to comment