dragging and dropping a directory crashes Love on Mac

Issue #1347 resolved
Blake Wyatt created an issue

I'm not sure if this is an error specific to my Mac or all Macs, but any program I run (even a blank program) automatically crashes whenever I drag and drop a directory onto it. It doesn't matter what's in the directory either.

Before the program crashes, it prints a single line of text to the Terminal saying "Trace/BPT trap: 5". I also tested to see if the love.directorydropped callback is called before the program crashes and it isn't.

I was able to obtain a crash log from my Mac's system.log file which says:

Oct  4 16:13:00 75-112-94-220 com.apple.xpc.launchd[1] (org.love2d.love.17272[655]): Service exited due to signal: Segmentation fault: 11 sent by exc handler[0]

This only happens on 0.11.0 (not 0.10.2) and isn't happening on Windows either.

Comments (8)

  1. Alex Szpakowski

    I can't reproduce this (using macOS 10.13). I've attached the build of 0.11 I'm using, if you want to test with it.

  2. Blake Wyatt reporter

    Yes! This works! I tried updating xcode and macOS to the latest version, replacing the Love frameworks in /Library/Frameworks/, and recompiling using platform/xcode/love.xcodeproj in the latest source code, but I keep producing a bad binary.

  3. Alex Szpakowski

    My build might be using a newer SDL2.framework compared to yours – you could try replacing love.app/Contents/Frameworks/SDL2.framework in your love.app with the .framework from my .app, and see if that fixes the crashes for you.

  4. Blake Wyatt reporter

    Wrong version of SDL framework when compiling the binary resulted in the error. Simple replacing it with the correct one fixed the binary.

  5. Log in to comment