bug: too high requirements, opengl/3d? for what?

Issue #1350 wontfix
Gerhard Lenz McKAY
created an issue

try to compile love seems need too high requirements relies on opengl!

why i need 3D if i wish to run 2D graphics? seems pretty ilogic!

Comments (5)

  1. Bart van Strien

    Love uses hardware-accelerated 2d graphics. It also gives users access to advanced gpu features like shaders. And the only way to have these things is.. you guessed it, OpenGL (or Direct3D).

    That said, love even runs on a raspberry pi, so it basically runs anywhere.

  2. Gerhard Lenz McKAY reporter

    love even runs on a raspberry pi, so it basically runs anywhere.

    there's no instruction to make it runs on first r-pi hardware.. it cosumes too many for stupid 2d graphics.. the tarjet its to made low end games for low end machines..

    if i have a powered GPU why use that engine.. i i have a powered GPU with "piixxxel shaaaders" i buy a game from steam, not a open source little game

  3. Bart van Strien

    there's no instruction to make it runs on first r-pi hardware

    It doesn't differ from the normal build instructions

    the tarjet its to made low end games for low end machines

    Your target might be, not everyone else's.

    i have a powered GPU with "piixxxel shaaaders" i buy a game from steam, not a open source little game

    Love is not a game. Games made with it needn't be open source, nor "little". Fun fact, there are love games on steam!

  4. Gerhard Lenz McKAY reporter

    Your target might be, not everyone else's.

    and not everyone have powered machine

    Love is not a game. Games made with it needn't be open source, nor "little".

    yeah of course, you have right , i want to provide fun games to those people that not have money to "upgraded" their hardware...

    a litle help may be apreciated in this way!

    Fun fact, there are love games on steam!

    i already noted, but are not so but I also noticed they are not the ones that sell the most, and not the most downloaded

  5. Raidho

    It is unfortunate that love doesn't have resources to support both older and newer versions of graphics APIs. You can however opt out of using latest version - earlier versions have lower requirements. With enough effort you can backport new features into older version, or replace the new graphics module with the old one.

  6. Log in to comment