upgrade to lua 5.2

Issue #367 wontfix
Anonymous created an issue

its time to have an task :-) : upgrade to lua 5.2

Comments (9)

  1. Anonymous

    A switch to LuaJIT, which already includes partial Lua 5.2 compatibility, would be more beneficial IMO.

  2. criptych

    For the record, I support this, but note that Lua 5.2 introduces some language changes that could affect existing projects (though probably not in any game-breaking way).

  3. Shlomi Fish

    I am unable to build love2d-0.8.0 from source on Mageia Linux Cauldron with lib64lua-devel-5.2.2-1.mga3 - the ./configure fails with this error:

    checking for library containing lua_pcall... no
    configure: error: Can't LÖVE without Lua

    The problem appears to be that in lua-5.2.x, lua_pcall was converted to a macro which makes linking with it as a symbol fail.


    -- Shlomi Fish

  4. Shlomi Fish

    @Bart van Strien : after unpacking the love-0.8.0 source package and running ./configure with this flag, I am getting informed that «configure: WARNING: unrecognized options: --with-luaversion» and configure fails with the same error. Is this option present only in the development version of löve2d? If so, when can we expect a new stable release?

  5. Alex Szpakowski

    LÖVE 0.9.x+ uses LuaJIT 2.0 (which includes partial Lua 5.2 support.) At this point I don't think we'd switch back to standard Lua for official builds.

    It is also possible now to use 5.2-compatibility with LÖVE if you do your own build.

  6. Log in to comment