Port to Box2D 2.1.x

Issue #37 resolved
Anonymous created an issue

it would be great to be able to use the distribution's box2d ( currently 2.1.x ), so its necessary to port löve to be able to work with the new api and then kick the bundled box2d out. thanks already!

Comments (5)

  1. Bill Meltsner

    Yeah, 2.1 makes some major API changes to things like callbacks; it's not a trivial matter to upgrade, but it is on my list.

    As far as kicking the bundled Box2D out - it should be noted that Ubuntu only has 2.0.1 in the main repo, and many Linux distros don't have it at all. (Not that it's difficult to compile or anything.)

  2. Log in to comment