Issue #3 resolved

DirectX SDK for Windows 8

kevinclancy
created an issue

It's arguable whether this is an issue at all, but I thought I would report it regardless. The DirectX SDK linked to in the wiki is not compatible with Windows 8. Instead, Windows 8 users need to download the Windows SDK, as far as I can tell.

Comments (8)

  1. kevinclancy reporter

    When I tried building megasource, it complained that I did not have the DirectX SDK. So I tried running the installer for the DirectX SDK, but that failed. The compatibility section for the DirectX SDK installer does not mention windows 8. I googled "Windows 8 DirectX SDK" and found that for windows 8, the DirectX SDK is included in the Windows SDK. I installed the Windows SDK and then was able to build megasource.

  2. Alex Szpakowski

    Your build of SDL2 will be missing Xaudio2 support then I believe (which probably doesn't matter for LÖVE, but it's something to keep in mind.)

    https://hg.libsdl.org/SDL/rev/d9ecdf71effb

    What sort of failure message was there for the DirectX SDK install? Are you sure it failed completely, or maybe only one component of it was not able to install correctly and it popped up a failure message (even though 99% of it installed fine) at the end? The latter happened to me before in Windows 7, IIRC.

  3. kevinclancy reporter

    It got all the way to the post-install operations. Specifically, it read "Installing Visual C++ runtime" right before it crashed. The installer reported Error Code: S1023. I googled a few posts about how to fix this. I will try them out.

  4. Alex Szpakowski

    And you're positive that nothing from the DirectX SDK actually installed? If I remember correctly, I got the same error in Windows 7 when installing the SDK but everything actually worked fine afterward (it successfully installed everything necessary to build SDL 2, the thing that failed didn't prevent anything from working.)

    You likely already have a later VC++ runtime, which might be why that part fails.

  5. Christopher Smith

    Actually, there's an easy fix for the SDK thing, just uninstall all your C++ Redistributable(s), then install the SDK, then instal the C++ Redistributable(s) again. It thinks you have a newer version of the SDK, basically, and won't let you install.

  6. Log in to comment