Issue #10 new

Auto-Refresh doesn't work

aristidesfl
created an issue

Auto-refresh doesn't seem to be working.

Tried both with file:// and http://

OSX 10.8.2 Chrome 24.0.1312.52 Tincr 1.3

Comments (4)

  1. dwatkinsweb

    The auto refresh doesn't appear to be working for me either without closing and re opening the developer tools. I can hit f12 twice and it the changes will take effect. The remote saving works fine.

    Config File:

    {
        "toFile": [
             {
                "from": "/static/js/([a-zA-Z0-9\\-_]+)/([a-zA-Z0-9\\-_]+)/(.+\\.js)",
                "to": "+lib/$2/static/js/$1/$2/$3"
            }, {
                "from": "/static/css/([a-zA-Z0-9\\-_]+)/([a-zA-Z0-9\\-_]+)/(.+\\.css)",
                "to": "+lib/$2/static/css/$1/$2/$3"
            }, {
                "from": "/static/js/([a-zA-Z0-9\\-_]+)/(.+\\.js)",
                "to": "+lib/$1/static/js/$2"
            }, {
                "from": "/static/css/([a-zA-Z0-9\\-_]+)/(.+\\.css)",
                "to": "+lib/$1/static/css/$2"
            }
        ],
        "fromFile": [
            {
                "from": "(\\\\|/)+lib\\1([a-zA-Z0-9\\-_]+)\\1static\\1css\\1([a-zA-Z0-9\\-_]+)\\1([a-zA-Z0-9\\-_]+)\\1(.+\\.css)$",
                "to": "/static/css/$2/$3/$4?body=1"
            }, {
                "from": "(\\\\|/)+lib\\1([a-zA-Z0-9\\-_]+)\\1static\\js\\1([a-zA-Z0-9\\-_]+)\\1([a-zA-Z0-9\\-_]+)\\1(.+\\.js)$",
                "to": "/static/js/$2/$3/$4?body=1"
            }, {
                "from": "(\\\\|/)+lib\\1([a-zA-Z0-9\\-_]+)\\1static\\1css\\1(.+\\.css)$",
                "to": "/static/css/$1/$4?body=1"
            }, {
                "from": "(\\\\|/)+lib\\1([a-zA-Z0-9\\-_]+)\\1static\\js\\1(.+\\.js)$",
                "to": "/static/js/$1/$2?body=1"
            }
        ]
    }
    

    OS: Windows 7

    Language: Python/Django1.4

  2. juristr

    Having the same issue here. Only when I close/re-open devtools the sources get refreshed correctly, however the executed JavaScript code doesn't seem to match the shown sources (see img below)

    See img here: http://imageshack.us/photo/my-images/854/tincrautorefreshbug.png/

    In the console I'm only seeing 1 error: "Uncaught LiveEdit Failure: Blocked by functions on stack"

    Tincr config: http web server Auto-Refresh: on Auto-Save: on Win7 (x64) 27.0.1451.6 canary

  3. ryanackley repo owner

    Thanks, I'll look into it. Sometimes, v8 throws an error when trying to do hot swapping of javascript but tincr doesn't display it.

    In Tincr 2.0, javacript live reloads will cause a full page refresh by default.

  4. Log in to comment