browse button doesn't work (Ubuntu 64bit, Chrome 26.0.1410.63)

Issue #22 new
tomwagner
created an issue

Running lastest version from git. It writes this error in console log:

Error in event handler for 'undefined': Object #<HTMLEmbedElement> has no method 'launchFolderSelect' TypeError: Object #<HTMLEmbedElement> has no method 'launchFolderSelect'
    at Object.ProjectManager.launchFolderSelect (chrome-extension://nkngfidapheffklmniamacponkhdikfc/ProjectManager.js:61:21)
    at chrome-extension://nkngfidapheffklmniamacponkhdikfc/background.js:13:24
    at chrome.Event.dispatchToListener (event_bindings:390:21)
    at chrome.Event.dispatch_ (event_bindings:376:27)
    at chrome.Event.dispatch (event_bindings:396:17)
    at miscellaneous_bindings:164:24
    at chrome.Event.dispatchToListener (event_bindings:390:21)
    at chrome.Event.dispatch_ (event_bindings:376:27)
    at chrome.Event.dispatch (event_bindings:396:17)

Comments (19)

  1. Eric Butler

    Well, after fooling around with this for the better part of my afternoon (I have the bug too, rendering this plugin dead in the water), the best explanation is that I could come up with is the libaray is simply built without the launchFolderSelect method. I started debugging and found that window.nativeFileSupport just plain does not have a method called launchFolderSelect.

    After investigating the npapi plugin, I was confused when I clearly could see the method in the source. So then I decided to build the lib myself, only to find that it worked perfectly when I built it myself. Then I noticed the timestamp on the last commit on the x64.so (on my x64 linux/chrome setup seems to load this lib). It seems to be built before the launchFolderSelect method was added to the api of the plugin.

    Long story short, it seems like you just need to rebuild the library yourself to get it working.

    @Ryan Ackley -- I really wanted to help you out with a pull request fixing this bug, but if I've debugged this correctly, it seems you just need to rebuild the x64 and the .dll I think).

  2. tomwagner reporter

    rezzafr33 - you will have to use build steps from page https://bitbucket.org/ryanackley/npapi-chrome-file-api/src and compile NPAPI-chrome-file-api in fbbuild directory by make command. Than you will have to solve library dependencies. After compilation you copy npNPAPIFileIOforChrome.so file from fbbuild/bin/NPAPIFileIOforChrome to your tincr directory and replace original file. It worked for me on ubundu 12.04. Hope it helps.

  3. Taufan Rezzafri

    @tomwagner thanks for replying, the problem is cmake could not find correct path for gtk headers, doesn't it happen on ubuntu 12.04?, somehow i manage to solved it, roughly :p, by creating symlink to /usr/include directory for every missing required headers. btw i am on 64bit ubuntu 13.04

  4. Ryan Ackley repo owner

    try using

    sudo apt-get install libgtk2.0-dev
    

    or something along those lines. I'm no Linux expert. I didn't have to do anything special besides using apt-get to get it to build.

  5. King Bowser

    The makefile and related configurations are generated incorrectly in such a manner that many compiler flags are not included.

    Here's what I had to do:

    export CPATH=$CPATH:/usr/include/gtk-2.0
    export CPATH=$CPATH:/usr/include/glib-2.0/
    export CPATH=$CPATH:/usr/lib/glib-2.0/include/
    export CPATH=$CPATH:/usr/include/pango-1.0/
    export CPATH=$CPATH:/usr/lib/gtk-2.0/include/
    export CPATH=$CPATH:/usr/include/atk-1.0/
    export CPATH=$CPATH:/usr/include/gdk-pixbuf-2.0
    export CPATH=$CPATH:/usr/lib/x86_64-linux-gnu/gtk-2.0/include
    export CPATH=$CPATH:/usr/include/cairo
    export CPATH=$CPATH:/usr/lib/x86_64-linux-gnu/glib-2.0/include
    export CPATH=$CPATH:/usr/include/glib-2.0
    

    Such a PITA.

  6. Log in to comment