Error: Intellisense out of date raise when i use refector

Issue #33 resolved
Yann Lebel
created an issue

First very nice extension, finally found an extension that do the job properly.

But unfortunately since I install CodeMaid I have an error each time i use the refactor to rename a property, variable or method.

The error is : "Binding faled because IntelliSense for source file '[PathOfTheFile]' is out of date.

I use the default configuration I just changed the possible of the BuildProgress window.

I use Visual Studio 2010 SP1 : 10.0.40219.1 SP1Rel And .Net 4: 4.0.30319 SP1Rel

Comments (12)

  1. Steve Cadwallader repo owner
    • changed status to open

    Hi Yann_Lebel -

    Thanks for the nice comment. :)

    I think that error message is due to automatic cleanup being triggered during the refactoring which is similar to Issue 26. I already have made a code change for that issue which will be available in the next release.

    Hope it helps and thanks for the feedback, -Steve Cadwallader

  2. Yann Lebel reporter

    That's great, do you have any idea when you will release it?

    Because i would like to deploy your extension in my team but if you plan the release to be done in more than one month i will prefer wait a little bit.

  3. Steve Cadwallader repo owner

    Hi Yann_Label -

    I'm planning on an alpha and a beta release before the next big v0.4.0 release due to a lot of new functionality that will be coming out. I don't have a firm time table since it is a side project but I'm hoping to have the alpha out by the end of the month.

    If you want a temporary workaround for the issue you listed above, if you turn off "Auto cleanup on file save" then CodeMaid shouldn't be performing any actions during the rename refactoring operation you mentioned.

    Hope it helps, -Steve Cadwallader

  4. Steve Cadwallader repo owner

    Hi Yann_Label -

    There is a new v0.3.8 ALPHA release of CodeMaid now available that includes the changes mentioned. Hopefully it resolves the issue you were seeing.

    Any questions/issues, please let me know. -Steve Cadwallader

  5. Steve Cadwallader repo owner
    • changed status to open

    Hi Yann_Label -

    Can you get this behavior to reproduce consistently? If so, does it still occur if you disable the "Auto cleanup on file save" configuration option? If so, does it still occur if you uninstall CodeMaid?

    Thanks for the information, -Steve Cadwallader

  6. Yann Lebel reporter

    It's not consistent it's more random it happen only with the Auto Cleanup enabled and when you refactor the field multiple time in a very short period. Let say you have a field _myField and for each letter you add or remove you refactor your class, in this case you might see the crash (it's better to test with a field that appear many time in your class). If you do only one refactor and you do other modification after the crash does not happen.

  7. Steve Cadwallader repo owner

    Hi Yann_Lebel -

    Which version of Visual Studio are you using? I tried to reproduce this, but I haven't been able to yet. I added one letter at a time, refactoring after each character, several times in a row without issue.

    One other idea would be to double-check that in CodeMaid's configuration, under Cleanup->Remove if you have "Remove unused using statements" checked you also have its sub-item "Except during automatic cleanup on save" checked as well. These are both enabled by default so they should already be set.

    Hope it helps, -Steve Cadwallader

  8. Yann Lebel reporter

    I use Visual Studio 2010 SP1 : 10.0.40219.1 SP1Rel and both option are checked yes.

    Is it possible that it's because i installed the alpha version without to uninstall the previous version?

  9. Steve Cadwallader repo owner

    Installing the alpha version would have uninstalled the previous version for you, so that shouldn't be an issue.

    If possible, can you give a concrete example and maybe even a sample stripped down code file that exhibits the issue?

  10. Yann Lebel reporter

    The issue seems to have disappeared i cannot reproduce it again. Maybe it was because my intellisense file was corrupted because of the previous version and visual studio didn't refresh it properly before.

    Anyway now it works perfectly so thanks again and i think this issue can be closed.

  11. Log in to comment