Issue #24 wontfix

django-jsonfield installs the python package jsonfield

Daniel Rech
created an issue

In my setup this conflicts with the already installed "jsonfield" package.

If i install jsonfield:

pip install jsonfield

(https://github.com/bradjasper/django-jsonfield)

And then I install django-jsonfield:

pip install django-jsonfield

The data of the jsonfield package is overwritten.

I feel that if the package is called "django-jsonfield" it should install its content to maybe "django_jsonfield" but not "jsonfield". What is your opinion on this?

Comments (4)

  1. Daniel Rech reporter

    Both packages have a different API. I noticed this "issue" because I use the "load_kwargs" param with jsonfield and a dependency uses django-jsonfield:

    jsf = jsonfield.JSONField(load_kwargs={'object_pairs_hook': collections.OrderedDict})
    

    After eventlet (https://pypi.python.org/pypi/eventlet/) installed django-jsonfield my original application wasn't working and I got "Unknown kwarg load_kwargs" error messages.

    The only solution would be to merge both projects or to rename one. I expect a package to be named similar to the name it has on pypi and this clashes here.

  2. valtron

    Daniel has a point. Given the popularity of both packages, it's a real possibility that a project might have two dependencies, one of which uses jsonfield, the other django-jsonfield.

  3. Log in to comment