v0.9.4 assumes Django>=1.5
My workplace is currently on django 1.3.7 and using gargoyle. When building a dev environment today, gargoyle installed the latest of django-jsonfield, 0.9.4, which assumes it can import
django.utils.six, (but which only appears to have been added to django 1.5). As such, the developer got an ImportError.
Not sure if this is something you want your library to handle, but was certainly a headache for us. I'll leave a note with the gargoyle folks as well.