Issue #15 resolved

can't check if LDAP is working

Anonymous created an issue

I can't find any information about the LDAP configuration.

I configured LDAP server in the configuration part but I can't check if this is working.

How can I add a user with using LDAP instead of creating an account?

Thanks!

Comments (13)

  1. Sebastian Sdorra repo owner
    • changed status to open

    You must configure your LDAP-Server in the gernal configuration panel and then you should be able to login with an ldap account. The account for the user is created at the first login.

  2. Anonymous

    okay, that means in case I misconfigured something LDAP login is not working? There is no configuration check in advance?

  3. Sebastian Sdorra repo owner

    The LDAP support works! The only problem is a missing test functionality. You can configure your LDAP-Server in the settings, logout and login with an LDAP-Account. The Authentication is a chain authentication. You can always login in as scmadmin.

  4. Anonymous

    With try and error I was able to configure LDAP - it's working but it would be nice to have some configuration checks.

  5. Anonymous

    I'm having a similar problem. I configured my LDAP connection but whenever I try to login with a ldap user I get "[LDAP: error code 34 - invalid DN]"

    I have copied my ldap configuration from other tools that also use the same ldap server for authentication. How can I get a more detailed log or can anyone help me figuring out what seems to be the problem?

  6. Anonymous

    Hi,

    Apparently in my case, for some reason I have yet to identify, the plugin seems to be prepending a , do my base DN and for this reason, the outgoing DN is invalid. Is there a way to solve this on the config side?

  7. aikanaro79

    Hi Sebastian,

    I was the anonymous user that posted the previous 2 posts.

    I am using ldap plugin version 1.3, which was the version available from the Plugins 'menu'.

  8. Log in to comment