Issue #34 resolved

Configuring LDAP Plugin

docmarionum1
created an issue

I'm trying to use the LDAP plugin, but am unable to login using an LDAP account. I didn't change much, besides the Base DN, Connection DN and password. In the scm log file I see that there's an LDAP invalid credentials error:

12:39:51.111 [qtp1829923591-21] ERROR sonia.scm.auth.ldap.LDAPAuthenticationHandler - [LDAP: error code 49 - Invalid Credentials] javax.naming.AuthenticationException: [LDAP: error code 49 - Invalid Credentials]

Though I can't tell where the error is encountered (i.e. connecting to the server or authenticating the user I'm trying to log in as.)

I've tried playing around with the other options (filter, scope, etc,) without success. Any idea which options could be set wrong?

Thanks.

Comments (4)

  1. Sebastian Sdorra repo owner

    I think the bind credentials (Connection DN and Connection Password) are wrong. I have improved the logging of ldap-plugin, see 749f4c2ae398 . Could you please test the version 1.4-SNAPSHOT of the plugin and post the log lines for a ldap authentication.

    Install the version 1.4-SNAPSHOT:

    • Uninstall the ldap-plugin
    • close the plugin tab if the tab is open
    • change the end of the plugin repository url from "&snapshot=false" to "&snapshot=true"
    • go to the plugin page and install the version 1.4-SNAPSHOT of the ldap-plugin
    • restart the scm-manager
    • test the login with a ldap user
    • restore the old plugin repository url
  2. docmarionum1 reporter

    Ah, the problem was that I had the connection DN set as just cn=admin, rather than the full DN. I thought it would automatically concatenate the Base with the connection. (Maybe it's misleading because the default value just shows "cn=Directory Manager" rather than the full thing)

    But it's working now, thank you!

  3. Log in to comment