Issue #453 resolved

Scm Manager Service hangs/crashes

Anonymous created an issue

Hi, We’ve encountered a big problem with the scm manager lately.

The Problem is that the scm manager just hangs/crashes and doesnt respond at all. It seems to be in an endless loop or something like that. We're running it(v1.33) as a service on Windows Server 2008 R2 with Git and SVN and are using the ldap and active directory plugins. The problem occurs random. It seems like the service is waiting for a connection or something like that, because if we use the WebUi the browser tries connecting and don't get a timeout, no matter how long we wait. The same thing happens if we try to update a repo. it seems like Tortoise SVN(newest version) gets a connection accept but doesn’t anything after that. The problem started about 2-3 Weeks ago. We had this issue before, but only once a month or so. Now it's just about every 20 minutes. A service restart fixes it, but only for a short period of time. The logs didn’t help at all. I copied the last crashes in the file attached. It would be nice if anyone could give us a hint how to solve this, because we can't use the manager at all right now.

Comments (10)

  1. Sebastian Sdorra repo owner

    The log you've posted does not show a problem. Could please enable trace logging (https://bitbucket.org/sdorra/scm-manager/wiki/faq) and post the output if the error occurs again. When the error occurs next time could you please post the output of the following commands:

    jstack pid
    
    jmap -heap pid
    

    Replace pid with process id of the scm-manager java process. Both tools (jstack and jmap) are part of the oracle java jdk, if you are using the jre only version, please install the jdk.

  2. Sebastian Sdorra repo owner

    Could you check the memory of your server, because of the output of jstack:

    jstack 5448:
    5448: Not enough memory for this command.
    

    It looks like your machine runs out of memory. The jmap command seems to have a problem with the service wrapper. Please do the following steps:

    • stop the service
    • start scm-manager manually by calling scm-server.bat (without parameter)
    • call jps to get the scm-manager pid
    • wait for the issue and call jstack and jmap with the pid again
  3. Log in to comment