1. Sebastian Sebastian
  2. scm-manager
  3. Issues


Issue #110 resolved

Windows service w/ active directory

created an issue

I was running the server manually. Active directory authentication was working fine. Then, I installed scm-manager as a service. After that, active directory authentication no longer worked, even after I changed the windows service login user to be my account. After I stopped the service and restarted the server from the command line, active directory authentication worked fine. How can I help resolve this issue? This appears to be the only thing stopping us from using your tool as a repository server.

Thanks, Chuck

Comments (7)

  1. cdoucette reporter

    Two comments:

    1. I saw this message in the log file:<br> 19:04:21.660 [Thread-0] WARN sonia.scm.util.ScmConfigurationUtil - could not find ScmConfiuration file at C:\Documents and Settings\CDoucette\.scm\config\config.xml
    2. To work around this problem, I copied (target\scm-server\conf\) server-config.xml to .scm\conf:<br> C:\hg\scm-manager\scm-server\target\scm-server>copy conf\server-config.xml "%HOM E%\.scm\conf"
  2. cdoucette reporter

    I don't believe there is an issue with service vs. command line - so perhaps you can close this issue. I just don't understand the multiple configuration directories: C:\hg\scm-manager\scm-server\target\scm-server\conf C:\Documents and Settings\CDoucette\.scm\config The log message saying that no configuration was found was troubling. I also don't understand what runtime directory and/or configurations are used by the service.

  3. Sebastian Sebastian repo owner

    The scm-server/conf directory is configuration directory for the scm-server, that means applicationserver settings and logging. The .scm/config directory is the configuration directory for the scm-manager application itself, this directory is used by scm-server and scm-webapp and contains the complete informations for users, groups, repositories and configurations for plugins. How does you install the service? scm-server install?

  4. Log in to comment