1. Sebastian Sebastian
  2. scm-manager
  3. Issues

Issues

Issue #151 resolved

trouble using https with hg

stratosmacker NA
created an issue

Using hg (in this case tortisehg, however I did try commandline), trying to pull/push from the https link of my SCM-server gives me the error "URLError: [Errno 8] _ssl.c:503: EOF occurred in violation of protocol"

I can access the https web administration completely fine, so I'm not sure why hg doesn't work. I have tortise hg pointed at my cert.pem file, and I have my credentials in correctly. HTTP works fine, but I https is necessary as I http is not secure over the internet

Comments (12)

  1. Sebastian Sebastian repo owner
    • changed status to open

    Hi, could you try to use the insecure option from the command line:

    hg pull --insecure https://yourserver/scm/repo
    

    or

    hg push --insecure https://yourserver/scm/repo
    

    Just for check if the verification of the certificate fails. How did you configured ssl?

  2. stratosmacker NA reporter

    I tried the insecure option, and I received the same error. Note that the server is running Ubuntu Server 12.04, and SSL is set up as per the instructions on this project homepage. My laptop (the one im pushing and pulling with) is Debian testing 9with Linux Mint add on). At school today I tried https with tortisehg on a Windows XP machine, and the pull - update worked. Later I tried to push back to the server and it failed with a different error (can't remember what though).

    It appears that the version of SSL on my Debian is not fully compatible with that on Ubuntu?

  3. stratosmacker NA reporter

    Put the fingerprint in did not work. Also booted into another Linux distro, tried to clone my repo, got the same error with https. however I tried to clone another BitBukkit https repo, and it worked. So I'm very confused haha. Going to try a different computer next

  4. stratosmacker NA reporter

    Tried my brother's mac, and as with yours it worked great -_-

    the mac version of mercurial is 2.2, the Linux Mint Debian is 2.1 Maybe 2.1 has a bug? I'm going to try updating manually

  5. stratosmacker NA reporter

    (Reply via jess...@gmail.com):

    If you mean as in the tutorial, then yes. I think something is either wrong with the debian package, the package configuration, or the my personal configuration on that machine in regards to either HG or SSL. I tried again at school and it worked perfectly without the cert.pem. I'm going to try a different setup and ill keep updating, just in case someone else has this issue. And thanks again! On May 22, 2012 4:39 PM, "Sebastian Sdorra" <issues-reply@bitbucket.org> wrote:

  6. Log in to comment